Results 1 to 6 of 6

Thread: Cool DHTML Tooltip Script

  1. #1
    Join Date
    Nov 2004
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Cool DHTML Tooltip Script

    http://dynamicdrive.com/dynamicindex5/dhtmltooltip.htm

    I am having a problem with this script. The tooltips don't go where they are supposed to go in IE. I can't really explain it very well, but I'll try...

    ...The only thing I modified in the script is the CSS file...

    I am using the script to create a Staff Directory. When the user mouses over the name of a staff member, a tooltip comes up describing their main duties. But the tooltips change position depending on where the name is on the page. Sometimes it is completely off the page, othertimes it is right on top of the name, obscuring it from view. I have attached a .txt file of the source code so you can see it. I hope I make some kind of sense...thank you in advance for any help you can offer

  2. #2
    Join Date
    Nov 2004
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    help, anyone!

  3. #3
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    Hmmm it's very hard to debug your page, so there are so many things going on in it. If you could put the script in a clean page with just the changes you made to the CSS for it (and make sure the problem still exists), I can take a look.

  4. #4
    Join Date
    Nov 2004
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    OK. If I put it in a clean page, it works fine. So that means that it has to be something else in my page that is making it act strangely, right? Do you have any clue to point me in the right direction?

  5. #5
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    You need to try and find out where the problem occurs. Try slowly adding in bits of content back into the fresh page until it breaks again. That should help you find your culprit, most likely another JavaScript or CSS definition on the page.

  6. #6
    Join Date
    Nov 2004
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    ok thank you so much!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •