Results 1 to 5 of 5

Thread: Multiple content slider in tabs problem

  1. #1
    Join Date
    Mar 2007
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Multiple content slider in tabs problem

    Script: Featured Content Slider.
    http://www.dynamicdrive.com/dynamici...tentslider.htm

    I am trying to use the featured content slider in tabs. I followed the instruction to put multiple content sliders on same page, by giving a new id etc. The content that I get in each tab is by ajax. Now the problem is that it works perfectly in first round of going through each tab, but as to open a tab again the content slider jumps by multiple of how many times that tabs has been opened before. I don't know if I have explained it well but you can have a look at the page I am using it. You may not be able to see the source code directly but in FF you can probably see it in debug extension.http://http://test.joomlaprodigy.com/index.php...

    I would appreciate any help,

    thanks in advance
    Joomlafreak
    Last edited by joomlafreak; 03-28-2007 at 12:01 PM.

  2. #2
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    Warning: Please include a link to the DD script in question in your post. See this thread for the proper posting format when asking a question.

  3. #3
    Join Date
    Mar 2007
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Sorry about that. I edited my post to confirm with the format you mentioned.

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    It looks like you are initializing the rotation of the slider each time you load a tab and that the previous rotation is still continuing. So, you get double the rotation when loading a second instance of a tab, triple on the third, etc.

    This:

    Code:
    <script type="text/javascript" src="http://test.joomlaprodigy.com/modules/mod_fptabcasejp/js/fptabcasejp.js"></script>
    <script type="text/javascript" src="http://test.joomlaprodigy.com/modules/mod_fptabcasejp/js/jquery-1.1.2.js"></script>
    <script type="text/javascript" src="http://test.joomlaprodigy.com/modules/mod_fptabcasejp/js/jquery_tabs.js"></script>
    and this:

    Code:
    <style type="text/css">
    
    .contentdiv_text{
    float: left;
    margin-left: 230px;
    }
    .contentdiv_img{
    float: left;
    width: 200px;
    height:180px;
    }
    
    </style>
    should be on the top page in its head, not on the external page(s).

    And this should either be modified or, a different method should be used:

    Code:
    <script type="text/javascript">
    jQuery.noConflict();
    //jQuery(document).ready(function() {
       // jQuery.tabs("tab_container");
    
    jQuery(function(){
    jQuery('#tabs_container').tabs({ remote: true });
    });
    //});
    </script>
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  5. #5
    Join Date
    Mar 2007
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you very much for your reply. Though I can not do few of the things you mentioned but I know why it is occuring now. Will try some different way now.
    Once again thank you very much for your time and efforts
    with high regards
    Joomlafreak

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •