Results 1 to 5 of 5

Thread: HV Question

  1. #1
    Join Date
    Jan 2005
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question HV Question

    Script: http://www.dynamicdrive.com/dynamici...menu/index.htm

    HI.

    I know DD did not write this script but I'm hoping SOMEONE might have some ideas on what is happening on my site.

    I have the menu horitzontal, with the "StartLeft=0;" which according to the comments is the "offset y coordinate". Now on some of my pages, the menu is flush against the left but on other pages, it is not.

    For example:
    http://www.royaltyrecords.ca/services.html THIS PAGE IS NOT FLUSH WITH THE GREEN BAR ABOVE (ie. not right against the table)

    WHEREAS
    http://www.royaltyrecords.ca/tours.html THIS PAGE IS *ALMOST* FLUSH WITH THE GREEN BAR (ie. right against the table)

    Any ideas?

    Thanks!

  2. #2
    Join Date
    Sep 2004
    Location
    Little Falls, Roodepoort, South Africa
    Posts
    421
    Thanks
    4
    Thanked 1 Time in 1 Post

    Default

    Hi

    Try changing the file secondmenu_var.js line 29

    was: var StartTop=100; // Menu offset x coordinate

    to: var StartTop=96; // Menu offset x coordinate

    I did this and both seem to be snug and look OK.
    Very Best Rgds, Simonf :cool:
    __________________________________
    My Site | E-Mail Me

  3. #3
    Join Date
    Jan 2005
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Want to move left not up

    HI Simon,

    Thanks for that, but unfortunately that move the menu up not to the left. I am trying to get the left side of the red menu bar to line up with the left side of the green bar.

    Thanks.

  4. #4
    Join Date
    Dec 2004
    Posts
    177
    Thanks
    0
    Thanked 18 Times in 17 Posts

    Default

    The issue is the sizing of your pages...as soon as you jump onto a page that requires a vertical scrollbar, the table jumps to left a tad so that it remains centered. The menu does not. At least this explains it, I'll try to find a solution, if someone else doesn't have a quick one.
    Verzeihung!

  5. #5
    Join Date
    Jan 2005
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Lightbulb Grrr...

    minos,

    After playing with it for yet another several hours I know it is with the layout of the menu vs the main table. I have tried playing with the pixels but I sitll haven't gotten it figured out.

    Some really strange behaviour...
    - one person can click "refresh" and the menu will lign up properly.
    - when I load it, the tours and news pages come up properly but none of the other pages (not even if I hit refresh)

    Any help you could give me would be appriciated!

    One last thing... my table is set to be 750 pixels and yet the first row of spacers adds up to 757 pixels. How does HTML handle that? Which setting does it ignore? (Based on my testing I think it goes with the table setting, but then that leads to the question, where does it cut out the 7 pixels??) Are these the same 7 pixels that are causing the problem???

    Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •