Results 1 to 3 of 3

Thread: My site doesn't load properly in firefox

  1. #1
    Join Date
    Sep 2006
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default My site doesn't load properly in firefox

    www.nightlifebookings.ca

    The homepage works fine but when I click on a link it just shows code. It works fine in IE. I used Front page to make my site. Any ideas as to whats causing this?

  2. #2
    Join Date
    Dec 2004
    Location
    UK
    Posts
    2,358
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by trini shotta
    The homepage works fine but when I click on a link it just shows code. It works fine in IE.
    MSIE is broken (yes, you read that right).

    The content type served with those other documents is text/plain; plain text. The HTTP specification states that content types issued by a server are authoritative, therefore any user agent worth its salt will respect this information and render the content simply as text.

    MSIE violates this mandatory requirement by guessing at the content type when it comes across one that it doesn't like. Microsoft's excuse is that misconfigured Web servers will send the wrong content types, so documents won't be rendered as the author intended. They feel like it's there job to second-guess the server. However, this sort of thinking is perverse: if the real state of affairs isn't revealed because the browser covers for an inept Web developer or server administrator, the problem will never be found or fixed (unless a real browser is used).

    I used Front page to make my site.
    It shows. As usual, Frontpage as done a stand-up job of producing absolutely atrocious markup. I would strongly recommend that you learn to author by hand, or at least not use a WYSIWYG program written by Microsoft (certainly stay well clear of Office products).

    Any ideas as to whats causing this?
    Most servers use file extensions to determine the content type. It's a simple and efficient mechanism. As your files don't have extensions (that, or you're using a broken content negotiation feature), the server doesn't know what to send, so it uses a default. This is usually text/plain.

    The first thing you need to do is add .html extensions to the relevant HTML files. You then have two choices. You can either update the links in your documents to point to the altered file names, or you can enable MultiViews, thereby using content negotiation to pick the right file. You might not have permission to do the latter (depending on how your provider has configured the system).

    Mike

  3. #3
    Join Date
    Sep 2006
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    You're a genius man! Problem solved! I appreciate the advice. And if you happen to visit Toronto, let me know and I'll arrange a discounted limo from the airport to wherever your going! You know how to reach me! www.nightlifebookings.ca
    Thanks again!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •