In my opinion, use internet explorer with the latest version.