Blog Comments

  1. molendijk's Avatar
    TheWinterSolstice,
    Did you also comment out httpsiframesrc: "blank.htm" in the js-file?
    So:
    - set enableshim: false;
    - /* httpsiframesrc: "blank.htm", */.
    ===
    Arie.
  2. TheWinterSolstice's Avatar
    Dear ddadmin,
    Here is some more info, which may (or may not) be of use:
    I created a similar menu system using the latest "ddsmoothmenu". When I launch that page I get two problems:
    #1:
    An information bar pops with the msg: "An add-on for this website failed to run. Check the security settings in Internet Options for potential conflicts."
    #2:
    The page has an error. The error is:
    =========================================
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Timestamp: Fri, 27 Mar 2009 08:48:42 UTC

    Message: 'undefined' is null or not an object
    Line: 107
    Char: 2
    Code: 0
    URI: http://www.efficientenergysystems.or...dsmoothmenu.js
    ===================================================
    Again, to save you some headache and hopefully assist with the debugging, I need to state this: I uninstalled IE8 (as per Arie Molendjik's advice above), ran CCleaner to cleanup the registry, rebooted, reinstalled IE8 from scratch, rebooted, then reset it to factory defaults via |Tools |Internet Options |Advanced |Reset... and still I'm having issues.
    Oh, by the way, Im using the latest JQuery which is 1.3.2. (JQ is required for this menu)
    Thank you much much for your willingness to help. I hope that in some way my (mis)adventures will turn out to be useful, ferreting out any issues with IE8. And to think that I once was such an IE fan. What a pain IE has become...
    Best Regards & Gratitude,
    TheWinterSolstice
  3. TheWinterSolstice's Avatar
    Hello ddamin, Much gratitude for your willingness to help.
    When I set enableshim to false, the page contents does not disappear (improvement!) however, the drop-down menus do not open when I hover above an option where there is a dropdown.
    Information: IE8 shows an error icon in the bottom left corner. When I click on it I get the following error (the double dashes are mine, for separation):
    ================================================
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Timestamp: Fri, 27 Mar 2009 08:18:23 UTC

    Message: Unspecified error.
    Line: 228
    Char: 3
    Code: 0
    URI: http://192.168.0.10/kvar/site/ddlmenu/ddlmenu.js

    Message: Unspecified error.
    Line: 228
    Char: 3
    Code: 0
    URI: http://192.168.0.10/kvar/site/ddlmenu/ddlmenu.js

    Message: Unspecified error.
    Line: 228
    Char: 3
    Code: 0
    URI: http://192.168.0.10/kvar/site/ddlmenu/ddlmenu.js

    ==========================================
    FYI, there are three items in my "main" menu with ddl's. I'm guessing this is why the error appears thrice.

    I hope I'm being clear and coherent with my descriptions.
    Thank you for your help.
    Best Regards, TheWinterSolstice
  4. ddadmin's Avatar
    TheWinterSolstice:
    Inside the .js file, what if you turned off the IFRAME shim feature:

    Code:
    enableshim: false,
    Do you still get the same issue? FYI for me All Levels Menu works fine for me in IE8 (official release).
  5. molendijk's Avatar
    Hi TheWinterSolstice,
    I don't have IE8 installed on the machine I'm working on right now. I installed it on a computer on my work. I'll check monday, when I'm returning from some place abroad. Just for now: I simply installed the official version, and didn't have a beta version first. Perhaps you should uninstall everything, then install the official IE8-version and see what happens?
    ===
    Arie.
  6. TheWinterSolstice's Avatar
    Hi Arie Molendjik, Thank you for the reply. On my end however when I go to the link you provided, the same thing happens to me. Here are the details: What happens is when I hover above a menu item that has a down arrow, instead of the drop down menu appearing, the whole page disappears and only the horizontal menu is displayed. When I click on the arrow, the page reappears, but the drop down does not appear.
    I am using the official version of IE8 and since I had the beta installed prior to that, I reset all the IE8 settings to factory defaults. So I had to set Scripting to Allowed, otherwise the JavaScript wouldn't work.
    I tried two things: to activate compatibility view, which didn't help. and I tried to allow popups, and that didn't help either.
    I would be most thankful for any suggestions.
    Best Regards,
    TheWinterSolstice
  7. molendijk's Avatar
    Strange, the All Levels Menu works in IE8 with me, see here.
    ===
    Arie.
  8. TheWinterSolstice's Avatar
    Hi all. First, thank you to DynamicDrive and the brilliant person or people behind it for the service.
    Now for my post:
    1. I have installed the official IE8 and I have noticed that the "All Levels Navigational Menu (v2.1)" is not working properly. I have tried it both in IE8 native and IE8 compatibility view and it is having issues in both modes.
    2. I would suggest to put IE8 related comments and fixes in the page of each menu, because it is more intuitive. Not everyone will think of coming to the Forums to get fixes.
    3. Is there a possibility to modify the "Smooth Navigational Menu (v1.02)" so that we can use a graphic for the background color? For example a repeating graphic that creates a gradient effect?
    Again, many thanks for the very useful functionality and information.
    Best Regards,
    TheWinterSolstice
  9. molendijk's Avatar
    IE8 won't allow you to replace the iframe with the text/html-object. IE still doesn't handle the object properly.
    ===
    Arie.
  10. jscheuer1's Avatar
    Thats right. I'm using the document.documentMode property in my latest script (Crawler) to check what mode IE 8 is in because when it is in IE 8 standards mode it doesn't have the problem with crawler marquees in a table that all other IE have. And yes, this makes things more complicated. Fortunately document.documentMode is undefined in all other browsers and is a getter and a setter, while in IE 8 it always has a value and is only a getter. This makes it fairly easy to work with.

    I've taken the tack of switching to cc on mode so I know I'm only dealing with IE 5 or greater, then doing a try catch to set document.documentMode to 2000. Then I know that the version number returned by querying the navigator object in IE will be less than document.documentMode, except in IE 8 if it is doing emulation.

    One other thing I noticed while I was in development with Crawler is that IE 8 can sometimes switch modes itself as you scroll down the page (reloading the page as it does this). I found this quite disturbing. That's why I recommend using a compatibility mode meta tag - as that will prevent your page from doing this.

    All that said, if you can have your script 'just work' in IE 8, that would be better than worrying about all this nonsense. This can often be the case, but it will limit what you can do, or at least how you can do it without running into compatibility issues.
  11. ddadmin's Avatar
    That's a lot of good info John; I wasn't aware that document.documentMode returned that info in IE8 actually. Personally though I think when it comes to IE8 compatibility, it basically should mean a script should work in both Compatibility and Standards modes. That's because regardless of what the webmaster does as far as declaring a specific doctype on his/her site, the user now has the ability to override that with his choice of one of the rendering modes. And I thought IE8 was supposed to simplify things for us developers.
  12. jscheuer1's Avatar
    IE 6 is still in wide use snookums.

    Anyways, just to add to what ddadmin has said about updating pages - to those in the know:


    1. If you know your page will work in IE 8 standards mode, use this meta tag:

      Code:
      <meta http-equiv="X-UA-Compatible" content="IE=8">
    2. If you know your page requires IE 7 rendering, use:

      Code:
      <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7">
    3. In javascript - if you want to know how the page is being rendered in IE 8, query this property of the document:

      Code:
      document.documentMode
      It will return the version number of the IE browser version (if any) being emulated. Otherwise, it will return 8.


    Notes: Meta tags should be in the head, first thing before the title tag. If using XHTML (you shouldn't, but I'll forgive you), meta tags should have the self closing syntax, ex:

    Code:
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
    When devising pages for possible use in IE 8 (basically any page you design now that the browser has been released), it is my opinion and makes general sense that you should specify rendering mode with one of the above mentioned meta tags or configure your server to do so. Otherwise, there is always a chance that IE 8 itself will render your page in a way other than it was intended.
  13. ddadmin's Avatar
    Ok, first script to be modified for IE8 is Dynamic-FX Slide-In Menu (v 6.5). To update, just replace "ssm.js" with the new one in the zip file.
  14. Snookerman's Avatar
    This also means that we don't have to support IE6 anymore which should make it easier to make our sites work in IE7 and IE8 since we don't need to care if they don't in IE6.

    Also, after playing around a bit with IE8, I have to say that I am really pleased, the final version has many improvements compared to the beta and I have to agree that it's up there next to Firefox (at least until Fx3.1 is released I guess) and I will use it a lot for browsing, mostly because of the tabs. Try it out before you throw those tomatoes.
  15. molendijk's Avatar
    Isn't there a danger of not knowing exactly what you are doing when you use a library?
    Apart from that, I must admit that jQuery does have very nice 'things'.
    ===
    Arie
    Updated 03-17-2009 at 07:23 PM by molendijk (correction)
  16. jscheuer1's Avatar
    In many cases though, this is just adding more work for the browser to do and/or linking to a host with less than optimal bandwidth available at the time the code is requested, slowing down your page. Ideally these external links to script libraries would speed things up because wide use would result in scripts being cached on the user end. However, with multiple versions, updates, the lack of consensus on which libraries to use, the actual scripts using the libraries going out of date due to updates to the libraries and a general lack of widespread enough use of the hosted libraries, it is probably still best to code in ordinary javascript, or if a library is used, include the most appropriate one for your script with its distribution.
  17. miob's Avatar
    awesome job
    thanx 4 all
  18. ddadmin's Avatar
    I've updated the .js file. Let me know if that fixes the issue in IE/Chrome.
  19. miob's Avatar
    please fix it in IE and chrome if it's possible, that would be great ;-)
  20. Snookerman's Avatar
    Guess what I found, latest version of jQuery:
    Code:
    http://code.jquery.com/jquery-latest.js
    or just:
    http://code.jquery.com/jquery.js
    and minified:
    http://code.jquery.com/jquery-latest.min.js
    Also, you could load the latest 1.3.x and 1.x.x respectively:
    Code:
    http://ajax.googleapis.com/ajax/libs/jquery/1.3/jquery.min.js
    or:
    http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js
    I have no idea how this works with the cache and whether it's better or worse to use these links, but it's useful if you don't want to change the links in all your pages or if you just want to download the latest version with just a few keystrokes.
Page 3 of 4 FirstFirst 1234 LastLast