PDA

View Full Version : Issues with Chrome Menu



sherb
05-27-2006, 01:15 AM
Chrome Menu
http://www.dynamicdrive.com/dynamicindex1/chrome/index.htm
-------
Last night I spent several hours trying to figure out the problems with this menu not working. By all accounts this should be pretty simple! The Chrome graphics don't show up -- only text boxes and a list menu. Also things get shifted around on the page. The cut/paste into the "head" works fine but the problem shows up when it is pasted into the "body". I also tried another pulldown menu. Same problem. I'm using Dreamweaver 8 and have downloaded the update. This made no difference.

I've gone over this a bazillion times :eek: ! Went through this forum earlier today to get some ideas. Tried using a blank page (cut/paste separately & select all from the demo page), looked for commas, checked to see if reference to the file was missing, etc. Same problem exists :mad:! I want to finish my website and get it up and running this weekend. Any suggestions????

This is from the chromemenu demo (the original), which works perfectly, by the way. (I've even changed menu, font, and bar size to experiment around.) The problem is that it doesn't work when copied.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
<title>Chrome CSS Drop Down Menu</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<link rel="stylesheet" type="text/css" href="chrometheme/chromestyle.css" />

<script type="text/javascript" src="chromejs/chrome.js">

/***********************************************
* Chrome CSS Drop Down Menu- Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for full source code
***********************************************/

</script>

</head>

<body>

<div id="chromemenu">
<ul>
<li><a href="http://www.dynamicdrive.com">Home</a></li>
<li><a href="#" onMouseover="cssdropdown.dropit(this,event,'dropmenu1')">Resources</a></li>
<li><a href="#" onMouseover="cssdropdown.dropit(this,event,'dropmenu2')">News</a></li>
<li><a href="http://cnn.com" onMouseover="cssdropdown.dropit(this,event,'dropmenu3')">Search</a></li>
</ul>
</div>

<!--1st drop down menu -->
<div id="dropmenu1" class="dropmenudiv">
<a href="http://www.dynamicdrive.com/">Dynamic Drive</a>
<a href="http://www.cssdrive.com">CSS Drive</a>
<a href="http://www.javascriptkit.com">JavaScript Kit</a>
<a href="http://www.codingforums.com">Coding Forums</a>
<a href="http://www.javascriptkit.com/jsref/">JavaScript Reference</a>
</div>

<!--2nd drop down menu -->
<div id="dropmenu2" class="dropmenudiv" style="width: 150px;">
<a href="http://www.cnn.com/">CNN</a>
<a href="http://www.msnbc.com">MSNBC</a>
<a href="http://news.bbc.co.uk">BBC News</a>
</div>

<!--3rd anchor link and menu -->
<div id="dropmenu3" class="dropmenudiv" style="width: 150px;">
<a href="http://www.google.com/">Google</a>
<a href="http://www.yahoo.com">Yahoo</a>
<a href="http://www.msn.com">MSN</a>
</div>

<p><b>Note:</b> To see how the menu looks with an alternate theme, just change the code:</p>
<pre>&lt;link rel=&quot;stylesheet&quot; type=&quot;text/css&quot; href=&quot;chrometheme/chromestyle.css&quot; /&gt;</pre>

<p>inside the HEAD section above to reference one of the three alternate CSS files instead: "chromestyle2.css", "chromestyle3.css", or "chromestyle4.css"</p>

<p align="center">Copyright 2006 <a href="http://www.dynamicdrive.com/notice.htm">Dynamic Drive</a></p>

</body>

</html>

ddadmin
05-27-2006, 09:28 PM
Please post a link to the page on your site that contains the problematic script so we can check it out.

sherb
05-28-2006, 02:43 AM
Here's the link...my file page doesn't resemble the original design with the menu in. Thanks for looking at this.

http://www.thesavvyherbalist.com/intro_testmenu.html

ddadmin
05-28-2006, 05:47 PM
Well, the obvious problem I see is that your reference to the .css file is incorrect:

http://www.thesavvyherbalist.com/chrometheme/chromestyle.css

In other words, if you input the above in your browser, it returns a "file not found".

sherb
05-28-2006, 10:44 PM
As mentioned above, my site is not up, which explains the reason why chromemenu.css, etc don't show. It was requested to see a file in question.

Is it better to post the entire coding of this page??

Thanks

ddadmin
05-28-2006, 11:54 PM
Yep, I need to see a "working" example on your page to see what problems you're referrring to despite following the script directions.

sherb
05-29-2006, 06:48 PM
Okay, all my files are loaded onto the server. I've noticed that the chromemenu is partially visable now. I'll also have to figure out why the graphics load like they do...but, that's another issue. :rolleyes:

(6/7/06 - site link removed. didn't rcv help to fix the problem)

sherb
06-02-2006, 02:16 AM
Hello -- it's me again!:D

Could someone please tell me how to correct the Chrome menu problem on my site? For some reason, the "chrome" portion isn't showing completely (oddly, the other problem worked out).

Thanks!