PDA

View Full Version : Why my page doesn't display the same way in your site



Galleon
05-09-2006, 04:05 AM
In this link: http://www.dynamicdrive.com/dynamicindex16/showhint.htm
that shows how to use the show hint topic.

I followed the instructions and copied the code, but it still didn't have the same output in your page.

The 'showhint' worked but the message didn't appear on the predefined hintbox. Is there something I missed out? Or this effect is not really part of what the site wants to share? ^_^;

pls help

djr33
05-09-2006, 04:44 AM
Please post a link to the page on your site that contains the problematic script so we can check it out.

Galleon
05-11-2006, 02:17 AM
www.geocities.com/zankoku_tenshi/prod.html

^_^ Sorry, I forgot to place the page. I was trying out scripts as I am just a newbie at this "programming" stuff. ^_^ Please forgive my inefficient scripting.:D
The problem was the "more info".

djr33
05-11-2006, 04:41 AM
I'm not sure what's going on here, so I'll let you wait for someone else to be able to help.
What's the "predefined hintbox" in the example of your site?

jscheuer1
05-11-2006, 04:49 AM
I think it is Geocities. Poor choice of a host for javascript. The page works fine in Opera which also doesn't show the Geocities added content. In IE and FF there is this Geocities sidebar on the right and the script malfunctions as you have described.

There may be a way to adapt the script to work on Geocities, I'll look into it.

jscheuer1
05-11-2006, 04:59 AM
Ooops, not the problem at all. What you have is an illegal entry in your stylesheet (highlighted red):


<style type="text/css">

#prodfocus
{
text-align: center;
padding: 3px;
font-family: Verdana, Arial;
color: #ACACAC;
font-size: 20pt;
font-weight: bold;
width: 300px;
}

#container
{
width: 600px;
background-color: #ffffff;
border: 2px solid #ACACAC;
align: center;
}

#prod
{
width: 100px;
}

#ahreflayout
{
text-align: left;
padding: 5px;
font-family: Verdana, Arial;
text-decoration: none;
color: #ff9800;
font-size: 10pt;
}

#prodrow
{
border: 2px solid #ACACAC;
text-align: center;
padding: 3px;
font-family: Verdana, Arial;
color: #acacac;
font-size: 10pt;
height: 60px;
}

<style type="text/css">

#hintbox{ /*CSS for pop up hint box */
position:absolute;
top: 0;
background-color: lightyellow;
width: 150px; /*Default width of hint.*/
padding: 3px;
border:1px solid black;
font:normal 11px Verdana;
line-height:18px;
z-index:100;
border-right: 3px solid black;
border-bottom: 3px solid black;
visibility: hidden;
}

.hintanchor{ /*CSS for link that shows hint onmouseover*/
font-weight: bold;
color: navy;
margin: 3px 8px;
text-align: left;
padding: 5px;
font-family: Verdana, Arial;
text-decoration: none;
color: #ff9800;
font-size: 10pt;
}

</style>

Remove it. The green one is invalid so, might as well get rid of it too but, it isn't causing the problem.

Galleon
05-11-2006, 05:14 AM
Wee, thanks!! I'll look up on it. :D

Galleon
05-11-2006, 05:17 AM
Ahihihihi, I blame it on my disorganization ability >.< The script is working all ready. thanks to dj33 and jscheuer1