PDA

View Full Version : XP SP2 blocking my javascripts



abu066
09-11-2004, 03:05 PM
I am a (very) amateur webmaster and have two sites that include simple javascripts: www.berkshirepigs.org.uk displays the date and www.shrublandpark.co.uk uses the HV menu from this site.

Problem: WinXP SP2 causes IE to 'block' both these scripts. Curiously, they all work fine on this (and other) websites. What am I doing wrong, or not doing? Would appreciate some guidance.

Regards,
Richard Carter
richard@rjcarter.net

cr3ative
09-11-2004, 05:39 PM
Hi Richard,

With SP2 on my computer, it will only prompt you to allow a script to run in an offline environment; if the problem still persists online, you should attempt to upgrade the scripts if possible.

SP2 has its good points, but unfortunately due to Microsoft's power we can't ignore it... i've had to make a lot of scripts on my site redundant due to tightened security.

Regards
cr3ative

abu066
09-12-2004, 05:12 PM
Thanks... I was hoping to avoid removing or editing the scripts.

What I can't understand is why the exact same scripts work fine on sites such as this one! Has anyone looked at www.shrublandpark.co.uk (http://www.shrublandpark.co.uk), www.berkshirepigs.org.uk (http://www.berkshirepigs.org.uk) or www.rjcarter.net (http://www.rjcarter.net) and noticed SP2's blocking of scripts? They are Ok on my pc, but that might be because I've already allowed the content once.

Cheers,
Richard

jsk
01-17-2005, 02:26 AM
Here's a workaround. Add ...

<!-- saved from url=(0013)about :internet -->

... just after your <HEAD> line.

cr3ative
01-17-2005, 05:00 PM
<!-- saved from url=(0013)about :internet -->

edit: apparently it does work. *whacks head against wall* :rolleyes:
Erm, mwinter, care to back me up on this one? I swear those are SGML delimiters.

edit2: I think we just found an Internet Explorer security exploit. Oh dear...


In no way could that possibly work. The fact that it is surrounded by <!-- and --> means the browser automatically ignores it. It is, in fact, a markup comment. Browsers never read them.cr3ative

abu066
01-17-2005, 06:39 PM
Perhaps cr3ative should test the theory before rubbishing it...

The scripts are only blocked when I'm working offline, ie loading the site from my hard drive. The sites online are fine.

This solution works perfectly - many thanks. Of course, it's not much more than a nuisance when I'm working offline, but this is worth knowing.

Thanks,
Richard