PDA

View Full Version : HV-Menu with flash-banner under Firefox/Mozilla



Axxaran
04-03-2006, 09:15 AM
Hi all,

i found some older posts to that theme, but maybe someone found a solution lately.

The problem again:

HV-Menu expands under a flash-banner. The parameters wmode=transparent work fine with IE and solves it there, but it doesn't work out under Firefox/Mozilla.

I tried:
<OBJECT ALIGN="" HEIGHT="86" WIDTH="300" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" id="banner1">
<PARAM NAME="movie" VALUE="banner.swf">
<param name="quality" value="high">
<PARAM NAME="scale" VALUE="noborder">
<EMBED src="banner.swf"
NAME="banner1"
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"
TYPE="application/x-shockwave-flash"
WIDTH="300"
HEIGHT="60"
quality="high"
scale="noborder" >
</EMBED>
</OBJECT>

=> not working under both browsers


<OBJECT ALIGN="" HEIGHT="86" WIDTH="300" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" id="banner1">
<PARAM NAME="movie" VALUE="banner.swf">
<param name="quality" value="high">
<param name="wmode" value="transparent">
<PARAM NAME="scale" VALUE="noborder">
<EMBED src="banner.swf"
NAME="banner1"
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"
TYPE="application/x-shockwave-flash"
WIDTH="300"
HEIGHT="60"
quality="high"
scale="noborder"
wmode="transparent">
</EMBED>
</OBJECT>

=> working under IE, but not under FF/moz.


Tried wmode="opaque" also doesnt work out.

Any new solution, tryout for this?

Thanx in advance
Axxaran

jscheuer1
04-03-2006, 03:28 PM
Sometimes it just cannot be done. If after applying wmode transparent to the embed tag, increasing the z-index of the menu's container or drop downs to like 300000 won't get it, look here:

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14201