PDA

View Full Version : Cannot get Slide up tabs menu to work properly



wkennyspain
08-15-2017, 12:59 PM
1) Script Title: Slide up tabs

2) Script URL (on DD): http://www.dynamicdrive.com/style/csslibrary/item/slide_up_tabs/

3) Describe problem:

Menu displays correctly, but when I hover over a menu item, the text is hidden. I have tried using this with inline style, and I have also put the CSS code in a separate CSS file and removed the <style> tags. Effect is the same on Chrome and Firefox

jscheuer1
08-15-2017, 02:53 PM
Sounds like you have some conflicting style(s). Probably having to do with a:hover, but I cannot be sure without seeing what you have. You can probably use the DOM Inspector to see what styles are being applied to cause this. Well I can probably, as I'm used to working with it. Otherwise you would just have to look through your existing styles to see where the conflict is. One thing you can try is to make sure the menu's styles are the last ones on or linked to the page. That will give them the best chance of avoiding conflicts without changing or adding anything, but depending upon the problem, might not be enough. To actually test anything, be sure to empty the cache and reload the page after any changes that involve external styles.

If you want more help, please post a link to a page on your site that shows the problem.

wkennyspain
08-15-2017, 04:28 PM
Thanks, John

I've removed all other CSS references to no avail. I've uploaded the test page here: http://estateagentsespana.com/almeria/test.shtml

jscheuer1
08-15-2017, 04:57 PM
You removed the span tags from the HTML part (this and similar):


<li><a href="index.html" target="_self" >Home</a></li>

need to be like:


<li><a href="index.html" target="_self" ><span>Home</span></a></li>

wkennyspain
08-15-2017, 05:10 PM
Oops. Thanks a million. Have scheduled an appointment with the optician tomorrow!