PDA

View Full Version : Random image script not showing ads



dingbatqueen
08-13-2017, 02:05 AM
1) Script Title: Random Image Script

2) Script URL (on DD): http://decoymag.com/classifieds/classifi.htm

3) Describe problem: When I preview in my browser from Dreamweaver, this script works PERFECTLY. However, once I upload it to the server, the ad image doesn't appear at ALL. I've tried countless different things and still can't figure it out. The advertiser is mad and I can't say that I blame him. This shouldn't be so hard! The ad image appears below the main 'CLASSIFIEDS' header and before the text which begins "Following is a complete list of..." If I link directly to the ad images alone, they appear correctly in the browser. BTW, I'm using most recent version of Opera with Win7 but that shouldn't matter in this case.

H E L P P L E A S E ! ! ! ! ! ! ! ! Before I get fired!!!! :O

THANK YOU SO MUCH!!!!!!!!!!!!!!!!!

jscheuer1
08-13-2017, 04:26 PM
There's really no problem I can see except in my one browser where I have adblock enabled. For some reason it recognizes these images as advertisements and blocks them. This could be due to the fact that the images are in a folder named 'advertisers'. Try using a different folder name like 'decoyimages' (avoid anything that has 'ad' in its name), move the images there and make sure to update the code to reflect the new location.

The browser cache may have to be cleared and/or the page refreshed to see changes.


A way to test this is to see if you have an adblocker program enabled for the page and if so turn it off and refresh the page, the image should show up.

dingbatqueen
08-15-2017, 12:20 AM
Hi John,

My ad blockers are turned off and still I can't see the ad. I'm going to follow your suggestions and see if it works. THANK YOU SO MUCH for your response; I appreciate it!! :)

-- Karen