PDA

View Full Version : HTTPS on my site breaks rssdisplay



redpis
03-01-2017, 05:33 PM
1) Script Title: RSSDisplay

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex18/rssdisplaybox/index.htm

3) Describe problem: I have recently bought a SSL cert and if I use https://www.chatteris.biz the rss display box on the index page doesn't initialise, I have made the paths relative but no joy.

Using www.chatteris.biz everything is fine, Is their a fix please

jscheuer1
03-01-2017, 06:26 PM
As long as everything, and I mean everything on your page and in the folders supporting this script and the in the support files themselves use the relative path, the network path, or the absolute path with the https specified, it should maybe work. However, remember that the feed itself is not SSL, so may be being rejected on that basis.

For example, in your rssdisplaybox.js script I see:


var rssoutputscript="http://"+window.location.hostname+"/rssbox/main.php"

That would have to be:


var rssoutputscript="https://"+window.location.hostname+"/rssbox/main.php"

This (the network path) should also work:


var rssoutputscript="/"+window.location.hostname+"/rssbox/main.php"

Check inside main.php (I will as well and get back to you if anything looks like it might need attention there or in the other files, all of which must be on the SSL partition) and see if there are any paths in there. If memory serves, there's a path to simplepie itself in there*, make sure it's SSL. If I remember correctly, that cannot be a network path, but can be either relative or absolute, as it's an include reference. And because of that, might not matter anyway, but never hurts to be thorough. Simplepie itself, at least not this version, shouldn't have any links or includes**.

And then you're going to have to be sure the browser cache is empty and refresh things.

But, as I say, even once your side of things are all secure socket, the feed isn't, unless of course it is. If the feed is available in an https version, use that. But this last bit might not be crucial. Let's make sure all the support files are free of non-secure link references first.

*Yes, I checked, but if you haven't changed it, it's relative so should be fine

**Actually Simple Pie itself has paths that are not ssl in it, but these are only used for videos, sound files, and other objects in the feed, and I believe only under certain circumstances. They're to third party scripts and standards and none of that would stop the overall feed script from working, but might prevent some of these embedded files in the feed (if any) from functioning as expected.

redpis
03-02-2017, 06:53 PM
Thank you John for taking the time to help me, it's all sorted now, I removed 'http' in rssdisplaybox.js and it works just fine.

Cheers

Ian