PDA

View Full Version : Floating iFrame: FF compitable version?



cyb.dr
11-21-2004, 06:32 PM
Hy,
i use the floating iframe script on my webiste julian4you.com. Because of different reasons i don't want to use the IE anymore. But with Mozilla Firefox the script ( http://www.dynamicdrive.com/dynamicindex17/floatiframe.htm ) doesn't work. Do you know how to make it compitable to FF 1.0? Or do you have a further script like this that works with FF?

Thank you,
cyb.dr

ddadmin
11-22-2004, 10:48 PM
I've made a note of this, and will see if anything has changed between NS6 and Firefox that eliminates a bug that caused us to make this script IE and Opera 7 only. If it has, we'll post an update to this script in the next couple of weeks.

cyb.dr
11-23-2004, 04:28 PM
Thank you a lot! Hope there is a way...

ddadmin
01-17-2005, 11:34 AM
Ok, it seems Firefox 1.0 returns a document height for the page within the iframe that's slightly short of its actual height, around 16 pixels. I couldnt' find out why this is the case, though the fix as a result is to detect FF1.0, and if true, add 16px to the iframe's height.

This is now done, and all Iframe SSI scripts have this fix in place.

gjordan3
02-01-2005, 01:31 PM
I am attempting to use the javascript "Iframe SSI script IE" to display upto two lines of text for a subset of the users that access my website. (For all other users, they should not see these two lines of text.)

I have run into problems with viewing these webpages on the MAC. (I have looked at IE and Safari.) The problem occurs in resizing the IFRAME pannel. (The panel always has the same size. Does not matter if content is included in the pannel or not.)

Do you have any suggestions?

Thanks for all your help,

George Jordan