PDA

View Full Version : HV menu not working with Opera 7.5?



FrankC29
09-10-2004, 06:17 AM
My Hvmenu works fine in every browser I've tried except Opera 7.5. In opera 7.5, the menu choice does not open in the correct frame, it only opens within it's own frame no matter if I select "_top" or "_blank" or a specific frame name in the .js file. It's kind of annoying because my site gets quite a bit of traffic and this version of Opera is becoming more and more popular. Any ideas?

sbode
09-11-2004, 08:35 AM
When selecting a script to use, first of all test to be sure how it displays in all major browsers when you are browsing scripts at Dynamic Drive. If you know you are going to have a headache from the get go, you can choose on that has similar properties and you can most likely configure it to appear almost the same with some tweaking.

If you are dead set on using the HVMenu, if your menu doesn't work, your site navigation is down, have dual navigation, a simple menu at the bottom of the page. Or if the menu travels, hide another menu underneath the DHTML menu so you clients have someway of getting around.

Scripts and iframes and frames do not behave the same with many scripts with Opera and there is no easy work-a-round. Does your menu work in Opera when it is the only script on the page?

One menu I have found that you can try is Milonic, they have free trials like on Dyanmic Drive they have a free Brother Cake menu, which works well with Opera I've found.

If the menu simply won't work, sometimes chalk it up to a learning experience and try another one. If you have problems with a menu loading because it is older script, the problem will probably not fix itself.