PDA

View Full Version : Ultimate Fade-in Slideshow Randam:false, Image Display Question



cpolk
04-29-2016, 06:16 PM
1) Script Title: Ultimate Fade-in Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/responsivedemo2.htm

3) Describe problem: We want to change our slideshow from being random to displaying the images in the list order, but when I change the Random attribute to false then every time you click on the slideshow it's starts at the beginning of the list.
Is there anyway in the code to make it so that when you click on the slideshow it goes to the next image on the list instead of starting over?
We tried adding buttons with the togglerid attribute and we did not like the look and even then when you click on the actual slideshow image it still went back to the top of the list.

Chase Polk

jscheuer1
04-29-2016, 07:21 PM
This not the standard behavior. When you click on the slideshow - regardless of whether it's in random mode or not, it will go to the link for that image if any. Otherwise it will simply pause until the mouse moves away from the slideshow.

Maybe you mean that each time you go to the page with the slideshow on it, it starts at the beginning. If that's the problem, then you can set persist to true so it will remember which slide it was on previously.

Or maybe you have done something that makes clicking on the show reload the page - like setting the href for each image to '#' or some other value that causes a reload.

In any case, if you want more help, please post a link the page on your site that has the problematic slideshow, so we can check it out.

cpolk
05-05-2016, 06:51 PM
Hey John,

Changing persist to true, does help the situation, but the slideshow does act like a link when clicked on. It does seem like it may be refreshing the page but I cant see anything in the code that would be causing that. We were hoping that there would be a way to make clicking on the slideshow load the next image on the list. Here is a link to the page with it set to randomize false and persist true: http://www.whiteboardps.com/

-Chase

styxlawyer
05-05-2016, 07:21 PM
The page is reloading because you have "_parent" in third position in every slide array, which is used as a link target. Position 2 in all the arrays is empty so the software doesn't know where to go when you click on the slide and is refreshing the current page in the same window. It doesn't make sense to have a link target without an URL so, if position 2 is empty then position 3 should also be empty.

Also you are using version 2.4 of the software and the latest release is version 2.6.1.

jscheuer1
05-05-2016, 07:30 PM
You do have a link for each image " " (a space character). That's the same as telling it to go to the current page. The target field is a red herring, Change " " to "". Example:


["images/home_slideshow/home_01.jpg", " ", "_parent", "GOFIT KETTLEBELLS "],

and all similar should be:


["images/home_slideshow/home_01.jpg", "", "_parent", "GOFIT KETTLEBELLS "],

You can also get rid of the target, but it doesn't matter:


["images/home_slideshow/home_01.jpg", "", "", "GOFIT KETTLEBELLS "],