PDA

View Full Version : PowerZoomer not working with jQuery greater than 1.6.4?



Chris52
04-16-2016, 02:52 PM
1) Script Title:
Image Power Zoomer v1.2

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex4/powerzoomer.htm

3) Describe problem:
I would like to use the Image Power Zoomer with an actual jquery version greater than 1.9. But the magnification with the mouse wheel doesn't work. Up to jquery 1.6.4 it works fine, but 1.7.0 and above there is an error.
Is there a new version or what can I do?

jscheuer1
04-16-2016, 03:23 PM
Here, using a plain text editor like Notepad, around line 85 in the script, add the highlighted:


$magnifier.outer.bind(ddpowerzoomer.mousewheelevt, function(e){ //bind mousewheel event to magnifier
e = e.originalEvent;
if (ddpowerzoomer.activeimage){
var delta=e.detail? e.detail*(-120) : e.wheelDelta //delta returns +120 when wheel is scrolled up, -120 when scrolled down
if (delta<=-120){ //zoom out
ddpowerzoomer.movemagnifier(e, false, "out")
}
else{ //zoom in
ddpowerzoomer.movemagnifier(e, false, "in")
}
e.preventDefault()
}
})

Save and use that version.