PDA

View Full Version : Resolved Problem with images not showing in slideshow



joac1424
08-10-2015, 07:23 PM
1) Script Title: Ultimate Fade-in slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem:

I'm using the Ultimate Fade-in slideshow, but I cannot get the images to show in the slideshow.
The slideshow is supposed to start when clicking on the green button on this page: http://joachimjepsen.dk/flyt-dig (the green button has the text: "Forstyr ham")

As you can see on the webpage I linked to above, there are no images showing - neither does they show when you click on the green button.

Here is the code I have used:


<div id="drawing" align="center">
<div id="fadeshow1" style="width: 400px; height: 400px; margin-left: auto; margin-right: auto;">&nbsp;</div><a id="flytDig" name="flytDig" href="javascript:startShow();"><img src="/images/slideshow/flyt_forstyrham.jpg" alt="" /></a>
</div>
<p>
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>
<script type="text/javascript" src="/fadeslideshow_mod.js">
// <![CDATA[
/***********************************************
* Ultimate Fade In Slideshow v2.0- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for this script and 100s more
***********************************************/
// ]]>

</script>
<script type="text/javascript">
// <![CDATA[
var mygallery = new fadeSlideShow({
wrapperid: "fadeshow1",
//ID of blank DIV on page to house Slideshow
dimensions: [400, 400],
//width/height of gallery in pixels. Should reflect dimensions of largest image
imagearray: [
["/images/slideshow/flyt_flue1.gif", "", "", ""],
["/images/slideshow/flyt_flue2.gif", "", "", ""],
["/images/slideshow/flyt_flue3.gif", "", "", ""],
["/images/slideshow/flyt_flue4.gif", "", "", ""]
],
displaymode: {
type: 'manual'
},
persist: false,
fadeduration: 700,
descreveal: "ondemand",
togglerid: ""
})
function startShow() {
var interval = 2500;
var endInterval = 1000;
document.getElementById('flytDig').style.visibility = 'hidden';
setTimeout('mygallery.showslide(1)', 0);
setTimeout('mygallery.showslide(2)', interval);
setTimeout('mygallery.showslide(3)', interval * 2);
setTimeout('mygallery.showslide(0)', interval * 3 + endInterval);
setTimeout("document.getElementById('flytDig').style.visibility = 'visible';", interval * 3 + endInterval);
}
// ]]>

</script>
</p>

The website is a joomla based website.

I hope you can help me sort this out :) :)

ddadmin
08-10-2015, 11:04 PM
The reference to fadeslideshow.js inside your <script> tag currently is broken: http://joachimjepsen.dk/fadeslideshow_mod.js

Also, when the page loads, there is another JavaScript error (which you can tell if you use your browser's console F12 key):


TypeError: jQuery(...).supersubs is not a function

joac1424
08-11-2015, 07:46 PM
The reference to fadeslideshow.js inside your <script> tag currently is broken: http://joachimjepsen.dk/fadeslideshow_mod.js



That was the problem.. Thank you very much, it's working just as it should now! :) :)