PDA

View Full Version : Cool DHTML Tooltip - not fully displaying text in IE10 custom Zoom view



mcovey
11-11-2014, 01:54 AM
1) Script Title: Cool DHTML tooltip

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex5/dhtmltooltip_dev.htm

3) Describe problem: Using the only the Developer's View code to make a test page, the tooltips display correctly in Chrome and Firefox and in IE10, but only if IE10 has the View > Zoom set to 100%. Any setting higher or lower results in the text box being cut off or not visible on the rollover. The problem does not occur on the actual Dynamic Drive demo page: http://www.dynamicdrive.com/dynamicindex5/dhtmltooltip.htm -- so I wonder if there is some additional CSS or JS in that page that is needed for the display in IE10 at custom Zoom settings.

Thanks!

jscheuer1
11-11-2014, 04:41 PM
If the zoom engine of a browser is too poorly coded, there's no way to fix the problems it causes with some pages. Other times a change in dynamic code or style can fix it. But it's impossible to know ahead of time. It's fine in IE 11. These custom zoom levels in various browsers were all initially a bit buggy, especially with dynamic content. The latest versions of the browsers are generally much better.

mcovey
11-12-2014, 07:24 PM
Thanks, John. I appreciate the fast response. I understand that IE11 corrects this zoom display issue.

I was mainly curious because the issue is already corrected in the Dynamic Drive script page, which has the demo text embedded in it. This page displays correctly even in IE10.
http://www.dynamicdrive.com/dynamicindex5/dhtmltooltip.htm

But the code snippet on the Developers page, used to make a standalone page,has the issue in IE10.
http://www.dynamicdrive.com/dynamicindex5/dhtmltooltip_dev.htm

jscheuer1
11-13-2014, 03:24 AM
If that's the case, I would recommend using the script as set out on the demo page and ignoring the developer's view, which might be out of date or simply have errors.

If you're still having problems, please post a link to a page on your site that shows the issue.