PDA

View Full Version : Ultimate Fade-In SlideShow v2.6 hyperlinks not working...



montypadre
06-30-2014, 03:12 AM
1) Script Title: Ultimate Fade-in slideshow(v2.6)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem: Hi everyone! Great scripts (I know it's an operator problem somewhere, :confused:, hah). I've got the above script installed in WordPress, in my theme's header file. I know I've enqueued the jQuery scripts right in the functions file. All the jQuery across all pages works fine, except for one major problem: I can't get the links in the Ultimate Fade-In Slideshow imagearray to work! The images work, the scrolling effect, everything works. The mouse pointer changes to a hand to indicate a link and the link is echoed in a tooltip message at the screen bottom. If I right-click and open link in new tab, it opens. When I test it in a Windows desktop environment in a notepad implementation and test in a browser, it works fine. It's just this one problem in my dev environment (Linode server runnin CentOS distribution in a LAMP). I've tried searching ten different ways, poring over the forums here, even the archives. I cannot figure out why it doesn't work. I'm thinking it's gotta be a jQuery conflict (I removed the validation script and tried it, didn't work). If anyone can help me with this I would be much obliged. Thanks very much for your help and for the great scripts!

UPDATE: It always happens that as soon as I ask a question on a forum like this I find the answer right after (usually cuz I didn't look at the previous threads well enough). Thanks for the support you guys! The problem turned out to be the secondary script that adds the mobile responsiveness, the touchSwipe script. There seems to be some sort of conflict between it and the main slideshow script itself - or the way I implemented them in my setup or somethin. I found what I was lookin for here (http://www.dynamicdrive.com/forums/showthread.php?76977-Reel-Slide-Show-Not-Linking). Again, thanks guys. I'm relatively new to the whole developer scene and I really can't get over the level of community I see in this whole scene. Ya'll f***in rock!

ddadmin
06-30-2014, 04:38 AM
What happens if you remove the script reference:


<script type="text/javascript" src="jquery.touchSwipe.min.js"></script>

from the HEAD of your page?

noobie123
10-09-2014, 11:41 AM
I tried this and now the links work.