PDA

View Full Version : Resolved Favicon confirmation please



theremotedr
10-01-2013, 08:39 PM
Hi,
Im wanting to use a favicon on my site.
I have added the image to the root directory & uploaded & also addedd the code <link rel="icon" href="/favicon.ico"/> to the page.

The site in question is as follows.
http://www.theremotedoctor.co.uk/

I do not see the icon on the tab.
I am using Firefox.
I do not know as to whether i have placed the code in the correct place or maybe i have not waited long enough for it to show.

Please could you just check for me if the code & placement of it is correct.
If either is incorrect please advise correct code & placement i need to change it to.
I have deleted the bookmark & also cleared the cache.

Many thanks.

Beverleyh
10-01-2013, 09:07 PM
I'm limited with what I can see as I'm on iPhone but this has always worked for me;
<link rel="shortcut icon" href="http://fast-edit.co.uk/favicon.ico" type="image/x-icon" />i read somewhere that its best to specify the full path (that might have been due to using templates though - one common header file for all pages, even those in sub-folders).

edit: I think John said a while back in another thread that you don't necessarily need the link tag at all - just having the favicon in the root folder will be enough for browsers to locate. I haven't tested that yet though.

theremotedr
10-01-2013, 09:34 PM
I have made an edit looking at your code.
Please take a look in the morning,thanks

jscheuer1
10-02-2013, 02:44 AM
http://theremotedoctor.co.uk/favicon.ico

is a 404 Not Found.

theremotedr
10-02-2013, 08:33 AM
http://theremotedoctor.co.uk/favicon.ico is now shown in the browser without the 404 code

I have also used this code shown below
<link rel="shortcut icon" href="http://theremotedoctor.co.uk/favicon.ico" type="image/x-icon" />

When looking at the page tab i see a dotted square at the moment.
Please can you check this out,many thanks.

http://www.theremotedoctor.co.uk/index.html

Beverleyh
10-02-2013, 10:14 AM
favicon shows fine in the address bar and browser tab in IE10 and Safari.

and browser tabs in Firefox, Chrome and Opera (I don't think these show favicons in the address bar)

jscheuer1
10-02-2013, 11:52 AM
It worked here in Opera, but since I had checked in Opera before when it was a 404, I had to refresh the page to see the favicon.

Other browsers may have cached the 404. If you don't see it right away, try refreshing.

Some browsers, IE in particular and older IE especially may take some time (days, even weeks) before they recognize the favicon, especially if the page was loaded in them before the favicon was present. Caching of favicon in these browsers is more persistent than others. Most modern browsers will change right away with a refresh. All will eventually.

theremotedr
10-02-2013, 12:10 PM
I now see it.
I am using Firefox and its just appeared.
I can confirm that i have only placed the favicon in the root folder and it is visable on each of my pages.

Many thanks for your time in helping me.