PDA

View Full Version : FadeSlideShow not showing 1 of 9 images in Chrome and Firefox, works fine in Safari



TracySherwood
09-11-2013, 07:12 PM
1) Script Title: Fadeshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem: I have used this slideshow in the past (on the same website where I'm having trouble now) with no problems. I even think when I changed the images recently it was working fine. But NOW (a few weeks later I think) I've noticed that 1 of 9 images is not showing up on Chrome and Firefox. It works perfectly in Safari though. I've looked at the code for the problem image, and it is following the same format as the other images and the image is uploaded. I checked this before I found that it worked fine in Safari.

Here is the site where I am having the trouble. The slideshow is on the right, almost half way down the home page:

http://www.ojaiworldmusic.org

If you are looking at this in Safari, the image that doesn't show on Chrome and Firefox is of a side view of a man in Native American clothing playing a woodwind instrument. It comes just after 2 images, 1 of a man, and 1 of a woman, both posing against a palm tree trunk. In Chrome and Firefox this space just comes up with a beige color.

Thanks for any help you can offer!

jscheuer1
09-11-2013, 07:59 PM
My Safari (for Win 7) cannot show it either, but perhaps one on a Mac could.

That image (I downloaded it):

ojaiworldmusic.org/images/owmf2013/RCarlosNakai_525.jpg

doesn't appear to actually be a JPEG type image. I have several image editing programs. Two are fairly sophisticated. The Gimp opens it and reports it as a "Photoshop image", and shows it at 525 300 pixels. The other is Paint Shop Pro 7 (old but still reliable) it opens it as a jpg, but at only 160 x 91 pixels, which I'm thinking is an embedded thumbnail, these can often be embedded in an image's EXIF or other data.

So, I suspect that you saved it in Photoshop or some other image editor as a Photoshop formatted image and just put a .jpg extension on it. What I would do is load it back into the image editor and save it as a JPEG formatted .jpg image. Or, if that's not something you know how to do, use this version (right click and 'Save As' - First make a backup copy of your version, just in case):

http://home.comcast.net/~jscheuer1/side/images/RCarlosNakai_525.jpg

BTW, the PSD version of the image (what's currently on the website) is about 888K, the above is about 49K. The PSD version is "lossless", I also saved a true JPEG version at 100% quality (virtually "lossless"), it's about 117K, if you're interested in that version, let me know. The 49K version is about 95% quality with Image Optimizer Pro's "Magic Compression" applied, except to the face. I preserved what I think is the original date of the image in its EXIF data's 'DateTimeOriginal' field for both of the JPEG versions - 6/19/2013.

djr33
09-11-2013, 10:05 PM
I'm on a Mac:
Firefox says it can't show it because "it has errors".
Safari does display it.

At first glance, it's hard to tell what's going on. That's partly because the file extension is only one cue on a Mac so you can still read a file in format X with extension Y.

Preview (the main image viewer) can open it without problems. I'd guess it's the same image-reading engine as in Safari (and Finder, where you see a thumbnail).

It's possible that this could happen when an image is simply corrupt. That's happened for me a few times with a digital camera, where only half of the data is saved and most of the image is random colors (usually blocks) or gray. Or I've even had that happen where the image is visually clear but still has some corrupt data in the file (maybe invisible information in the image, maybe metadata, I'm not sure). In that case, it's best to extract what you see (eg, via a screen capture or cut-and-paste as long as you're not accidentally then copying bad data too). Then it'll work.

Anyway, back to Preview-- it showed it just fine. But in the "Info" window I could see something about Adobe Photoshop Format. It also listed a couple layers in the image (a clear indication that it's not a JPEG).

So I tried Photoshop. Still on the Mac, where Photoshop isn't really a Mac program (just running there), so it probably does rely on the file extension.
Sure enough, I got "Could not complete your request because an unknown or invalid JPEG marker type is found."

Renaming it to PSD allowed me to open the file in PS. And there was the answer: it really is a Photoshop Document. It has two layers: one is the image, and the other is the white 'border' (actually a full rectangle filling the whole background underneath).

So that's the complete explanation if it matters.

John, your JPEG looks fine to me. So that's solved. But I just wanted to add the "whole story".

TracySherwood
09-12-2013, 12:11 AM
John and Daniel - thank you both for your quick detective work. I'll have to add this issue to my tool belt of problem solving.

You were both absolutely right! I don't remember if the original image was given to me by the site owner, or if I acquired it from the performer. I went back out to find another copy, and apparently there is a corrupted version out there floating around. One I tried to use gave me a similar "can't be opened in Photoshop" message. I was able to find an uncorrupted version and the slideshow now works perfectly in Firefox and Chrome. While you were answering me I found out it hadn't been working in IE either, so I'm assuming that is working fine now as well.

Thank you SO much! This is my first time in the forum and I had no expectation of receiving a solution within an hour. Amazing!

Tracy