PDA

View Full Version : DD Mega Menu not working only with Windows XP OS



TGGMike
06-26-2013, 11:07 AM
1) Script Title: DD Mega Menu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddmegamenu.htm

3) Describe problem: DD Mega Menu does not drop down (not showing) with Windows XP OS (home and professional editions) in all browsers. Works fine with all other OS in all browsers. Any similar problems or suggestions?:confused:

Beverleyh
06-26-2013, 11:59 AM
I don't have an XP machine with me at the moment, but from memory, this drop-down worked fine on XP - at least it did the last time I checked.

Are you referring to the demo page? James (or anyone else with XP access), can you confirm that the demo page is OK in XP please?

If you mean that your own installation of the script isn't working in XP on your own web page, please provide a link to your page where is its broken.

TGGMike
06-26-2013, 12:32 PM
The demo page is OK.

I'm using tables for the only drop down (<!--First mega menu (1) -->) in my own installation.

My Page: http://www.thegiftgallerypromo.com

Beverleyh
06-26-2013, 01:29 PM
Phew! That's a large web page and, at around 4000 lines, too much to go over in detail.

A few quick-skim observations that may be causing issues;

The DOCTYPE declaration is inconsistent. As taken from the W3C validator (http://validator.w3.org/check?uri=http%3A%2F%2Fwww.thegiftgallerypromo.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0)
The Public Identifier -//W3C//DTD XHTML 1.0 Transitional//EN declares the XHTML 1.0 Transitional document type, but the associated System Identifier http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd does not match this document type.

You link to 2 jQuery libraries - to version 1.6.4 in the <head>, and version 1.5.2 further down in the <body>, along with the ddmegamenu.css and ddmegamegu.js files, which should go in the <head>, as outlined in the demo page instructions. As for the jQuery - you only need to link to one library and having them both together on the same page is likely to be causing conflicts.

You also have other CSS styles and JavaScripts dotted throughout the body which could be causing problems.

I think you should try to clean up the web page as best as you can using the W3C validator http://validator.w3.org/ . Once you restructured things a bit and clean-up the organisation, it should be easier for you to troubleshoot.