PDA

View Full Version : disappearing navigation buttons while using css background



mrMC
06-25-2013, 03:36 PM
hi

i'm trying to make a little site and i made my back ground the first time just in html but it wasn't fullscreen.
so i've been looking around and made in css and it worked great.
when i was checking things i noticed that one of my navigation buttons on my slideshow disappeared.
i can't find what the problem is that's causing this
so i hoped you can look at it and tell me what i'm doing wrong.


bg in html: http://pastebin.com/EU9yyDsM
bg in css : http://pastebin.com/jMfL6mGh

fadeslideshow.js in attachments and you can chose the background, name bg.png or you can replace it.

thanks

jscheuer1
06-26-2013, 01:11 AM
Please include a link to a live page on your site that contains the problematic code so we can check it out.

mrMC
06-26-2013, 08:30 AM
Please include a link to a live page on your site that contains the problematic code so we can check it out.


hi
here are the 2 links
bd with html : http://199.115.230.147/htmlsite
bg with css : http://199.115.230.147/csssite

i hope you can help me out.

thanks

jscheuer1
06-26-2013, 08:53 AM
.

Your page is in violation of Dynamic Drive's usage terms (http://www.dynamicdrive.com/notice.htm), which, among other things, state that the script credit must appear in the source code of the page(s) using the script. Please reinstate the notice first.

Well, on the page where the button doesn't appear, the forward button is a 404 Not Found. But that's not the only problem. In order for anything to appear over the 'background', it must be positioned and have a higher z-index (this will work whether it comes before or after the 'background') or be positioned, come after, and have the same z-index or higher as the 'background'.

That's the principle. In practice in the layout of that page, just add the highlighted:


<div id="fadeshow2toggler" style="position: relative;width:250px; text-align:center; margin-top:10px">
<a href="#" class="prev"><img src="http://i1295.photobucket.com/albums/b635/Pieter_van_Gool/Knipsel_zps33810075.jpg" style="border-width:0" /></a> <span class="status" style="margin:0 50px; font-weight:bold"></span> <a href="#" class="next"><img src="http://s8.gva.be/ahimgpath/assets_img_gvl/2012/06/06/2269425/milquet-motorbende-satudarah-mc-kan-voorlopig-niet-verboden-worden-id3047614-1000x800-n." style="border-width:0" /></a>
</div>

mrMC
06-26-2013, 09:21 AM
.

Your page is in violation of Dynamic Drive's usage terms (http://www.dynamicdrive.com/notice.htm), which, among other things, state that the script credit must appear in the source code of the page(s) using the script. Please reinstate the notice first.

Well, on the page where the button doesn't appear, the forward button is a 404 Not Found. But that's not the only problem. In order for anything to appear over the 'background', it must be positioned and have a higher z-index (this will work whether it comes before or after the 'background') or be positioned, come after, and have the same z-index or higher as the 'background'.

That's the principle. In practice in the layout of that page, just add the highlighted:


<div id="fadeshow2toggler" style="position: relative;width:250px; text-align:center; margin-top:10px">
<a href="#" class="prev"><img src="http://i1295.photobucket.com/albums/b635/Pieter_van_Gool/Knipsel_zps33810075.jpg" style="border-width:0" /></a> <span class="status" style="margin:0 50px; font-weight:bold"></span> <a href="#" class="next"><img src="http://s8.gva.be/ahimgpath/assets_img_gvl/2012/06/06/2269425/milquet-motorbende-satudarah-mc-kan-voorlopig-niet-verboden-worden-id3047614-1000x800-n." style="border-width:0" /></a>
</div>




thank you .
you helped me very much