PDA

View Full Version : :: Smooth Navigational Menu (v2.0) in ie9



silviamo
05-28-2013, 10:58 AM
1) Script Title: :: Smooth Navigational Menu (v2.0)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm#ajax

3) Describe problem: It doesnt work in IE8 and IE9, please help, thank you.

Beverleyh
05-28-2013, 10:57 PM
Have you got a web page setup where we can see it not working?

Things worth checking;

- that the web page uses a standards invoking DOCTYPE
- that you're testing via web pages on a live server
- that the web page containing the menu markup is hosted on the same domain
- that the path to the web page containing the menu markup is relative to the current page
- that the web page containing the menu markup just contains the menu markup and not an entire web page structure (DOCTYPE, head and body tags, etc)
- that you're not using jQuery 1.10+ or 2+ where conflicts have recently been identified (John has been working on an update here: http://www.dynamicdrive.com/forums/showthread.php?74009-Smooth-Navigational-Menu-(v2-1) )

Anyways, please post a link to your page if you need more help and explain properly/fully what isn't working.

ddadmin
05-29-2013, 04:58 AM
It does work in both browsers you mentioned. Yes, please post a link to the page on your site that contains the problematic script so we can check it out.

jscheuer1
05-29-2013, 07:01 AM
Have you got a web page setup where we can see it not working?

Things worth checking; . . .

. . .

- that you're not using jQuery 1.10+ or 2+ where conflicts have recently been identified (John has been working on an update here: http://www.dynamicdrive.com/forums/showthread.php?74009-Smooth-Navigational-Menu-(v2-1) )

Actually I'm finished working on it, was when I put it up there. That's the new official version of the script. I'm just waiting for DD to notice it and put it up. You should use the updated 2.1 version (right click and 'Save As'):

5069

However, that has nothing to do with the problem you're having, that's most likely the lack of a standards invoking DOCTYPE. But it could be tons of other things.


It does work in both browsers you mentioned. Yes, please post a link to the page on your site that contains the problematic script so we can check it out.

Yep, works fine in those browsers. You should check the demo page:

http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm

If that's not working for you in IE 8 and/or 9, then it's most likely some setting(s) in your browser(s) that's the problem. But if the demo page works for you in those browsers, then it's probably the setup of your page (again, most likely the lack of a standards invoking DOCTYPE, but could be other things).

If it is the setup of your page and you want more help, please include a link to the page on your site that contains the problematic code so we can check it out.