PDA

View Full Version : Question about Image Zoomer jquery.min.js file



TedK
05-07-2013, 04:30 PM
1) Script Title: :: Featured Image Zoomer (now w/Multi-Zoom) v2.1

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/featuredzoomer.htm

3) Describe problem: I worry about using an external file I have no control over.

A: What happens if
http://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js
is down?
B: Why does jquery.min.js not work if you download it and I put it on my server?
C: What assurance do I have that the file will always be available?
Ted

Beverleyh
05-07-2013, 09:04 PM
Dan covered most of the answer here: http://www.dynamicdrive.com/forums/showthread.php?73346-Things-consider-to-reduce-server-untlization-in-php&p=292620#post292620

Basically, its a 3rd party service specifically designed to be linked to. If you wanted more assurance, you could download and host it yourself from the official jQuery website: http://jquery.com/download/ - I'm not sure why it wouldn't be working for you on your own server though so maybe you should provide a link to you page for us to see.

djr33
05-07-2013, 11:23 PM
Thanks for linking to that Beverley.

C: see the link in Beverley's post. There is no guarantee, but the intention is for it to be available-- many more web designers than just you will have major issues if it is no longer available. (Every 5 years or so you might want to look into updating the websites to work smoothly with modern browsers, but that's a somewhat separate issue.)

A: Your site won't work. But Google has very little downtime, and they will make every effort to keep high demand files like that available.

In short: while it isn't guaranteed to always/forever be available, it's generally reliable. We use it; you can too.


B: It will work. There's nothing wrong with that, except for potential updates (which aren't strictly necessary) and freeing up space/bandwidth on your host.
Are you asking "why does it say/suggest it won't work?" (it will; it's just standard to use the hosted version), or "why isn't it working right now when I try it?"? If you have a problem with your page, please provide a link to it. My guess is that one of the file paths is incorrect so that it's looking for the script in the wrong place.

TedK
05-08-2013, 03:08 PM
Thanks to both of you for your input.

Ted

jscheuer1
05-08-2013, 04:03 PM
I didn't want to add to the volume of responses until you had a chance to read what was already said. Here's my take -


Google is very reliable with 99% or better uptime.
If you use Google, chances are that many of your first time users will already have the Google script in cache, saving time loading your pages.
You can easily download a Google hosted script for your own use. Simply make a link to it on an .htm, or .html page, or any page you can view in your browser as HTML, example -

download.htm (call it anything.htm):


<!DOCTYPE html>
<html>
<head>
<title></title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

</head>
<body>
Right click and "Save As":
<a href="http://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js">jquery.min.js</a>
</body>
</html>

where:


<a href="http://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js">jQuery</a>

is the version you want. Notice that I have only 1.8 there. That will get you the lateset in the 1.8 series (1.8.2). Similarly you can use 1.6 for the latest in the 1.6 series (1.6.4), or just 1 for the latest in the 1 series (currently 1.9.1 - that may increase, the 1.9 series isn't necessarily finished yet, and 1.10 and 1.11 and 1.12, etc., even 1.9999 series are possibilities).

Or if you want a specific version, use it's full version, like 1.6.2 for example.

A Live example -

For the latest in the 1.8 series (1.8.2), right click and "Save As":

jquery.min.js (http://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js)

Once you download it, or as you are downloading it, you can name or rename it to its version so as to avoid confusion in the future. The one in the above example could be named/renamed:

jquery1.8.2.min.js



Another advantage of using the Google hosted script is that for a live page you may skip the protocol (the http: part):


<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>

If you have some pages hosted on either an SSL (https:) or on a regular layer (http:), or both, the user's browser will fill in the correct protocol. And since Google hosts both types, it will send the required one to your users.