PDA

View Full Version : Apple style Accordion Menu - ERROR after migration to new webspace



KingShinobi
03-27-2013, 03:09 PM
1) Script Title:
Apple style Accordion Menu
2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex17/ddaccordionmenu-apple.htm
3) Describe problem:
After bringing a website to a new webspace, the menu won't work anymore. I get the following error msg:

Warning: Parameter 2 to plgContentAccordionMenuApplestyle::onPrepareContent() expected to be a reference, value given in /home/catiooca/ct-austria.eu/html/libraries/joomla/event/event.php on line 67 Warning: Parameter 2 to botJoomfishAlternative() expected to be a reference, value given in /home/catiooca/ct-austria.eu/html/libraries/joomla/event/dispatcher.php on line 136 Warning: Parameter 2 to plgContentEmailCloak() expected to be a reference, value given in /home/catiooca/ct-austria.eu/html/libraries/joomla/event/dispatcher.php on line 136 Warning: Parameter 2 to plgContentLoadModule() expected to be a reference, value given in /home/catiooca/ct-austria.eu/html/libraries/joomla/event/dispatcher.php on line 136 Warning: Parameter 2 to plgContentPagebreak() expected to be a reference, value given in /home/catiooca/ct-austria.eu/html/libraries/joomla/event/dispatcher.php on line 136 {Accordion_Menu_Apple_style 120} Sales Support - Handelsvertretung - Zwischenhandel - Joint Venture Consulting - Strategieentwicklung - Projektmanagement - Business Relationships Marketing - Marktanalyse - Konzeptentwicklung - Marketingabwicklung Training - interkulturelles Training - Teamentwicklung - Verkaufstraining {/Accordion_Menu_Apple_style}

I'm using Joomla 1.5.16. You can see the error yourself under http://www.apl-online.at. I hope someone can point me in the right direction to fix the error.

Thanks a lot!

Beverleyh
03-27-2013, 03:46 PM
All of the errors suggest that the problem lies with the "event" files - event.php and dispatcher.php. A quick google search shows that they are part of something called "jEventDispatcher", which is a class introduced into Joomla 1.5, so I'm afraid that this is an issue with Joomla rather than a script from DD.

Its likely that your old web space used an older version of php. Newer versions of php, that your new web host will be using, do not support some aspects of the earlier versions of Joomla - that's why upgrades are recommended in Joomla and its add-ons.

You would be better off taking this to the Joomla forums to ask for their advice. Alternatively, search on "jeventdispatcher 1.5 php x.x.x" (with the version of php that your new web host is using inserted at x.x.x) as that will hopefully bring up solutions and fixes that relate to the problem more directly.

Beverleyh
03-27-2013, 04:03 PM
Something here that looks like a fix: http://www.codingconcepts.net/joomla-dispatcher-php-and-event-php-fix-errors/

Otherwise, a general google search is here: http://www.google.com/search?hl=en&ei=nBdTUYyWHIeX1AX8_IGYDA&q=event.php+dispatcher.php+1.5+errors+new+host&oq=event.php+dispatcher.php+1.5+errors+new+host&gs_l=mobile-gws-serp.12...29150.29150.0.30978.1.1.0.0.0.0.245.245.2-1.1.0...0.0...1c.1.7.mobile-gws-serp.OfkJW7eFXDw

KingShinobi
03-28-2013, 07:26 AM
ah thank you very much! the problem is fixed :)