PDA

View Full Version : Blending Image Slideshow Script



minnow312
03-23-2013, 12:13 AM
1) Blending Image Slideshow Script

2) http://www.dynamicdrive.com/dynamicindex14/image4.htm

3) Describe problem: Only on IE 10 do I get this error. It worked in all other previous versions of IE and still works on Firefox and Chrome.

Error Message: Unable to get property '0' of undefined or null reference
The error message cites this line in the code:
var blenddelay=(ie)? document.images.slide1.filters[0].duration*1000 : 0

Thank you for your help. Have loved the way this script looked on my website.

ajfmrf
03-23-2013, 01:15 AM
Please post a link to the page on your site that contains the problematic script so we can check it out.

minnow312
03-23-2013, 01:35 AM
Please post a link to the page on your site that contains the problematic script so we can check it out.


Thank you for taking the time to look at it. Here is the webpage where the error occurs.
http://www.RGodfreyHomes.com

jscheuer1
03-23-2013, 04:05 AM
Because Blending Image Slideshow Script is old and outdated, I'd recommend using:

http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

instead. However, you might be able to get that old outdated script to be serviceable. I'd try changing (from Step 1 on the demo page):


var ie=document.all

to:


var ie = /MSIE (\d+)/.exec(navigator.userAgent);
ie = ie && ie[1] < 10;

The browser cache may need to be cleared and/or the page refreshed to see changes.

minnow312
03-23-2013, 02:33 PM
Thanks so much! Put in the code change above and worked in IE 10. Am using it for a quick fix to give me time to put in the Ultra-Fade-in-Slideshow.