PDA

View Full Version : All Levels Navigational Menu (v3.02) - Extra <li> or dots



carolineleonard
03-22-2013, 12:44 PM
1) Script Title: All Levels Navigational Menu (v3.02)

2) Script URL (on DD):

[URL="http://www.seims-dlr.co.uk/index.php/2013-03-04-14-14-35/asset-hierarchy-b92"[/URL]
Site Access: temp
Password: temp

3) Describe problem: I keep getting extra <li> or dots in my menu bar but they are not in the code/tags. How can I remove them? See pic

4996

Beverleyh
03-22-2013, 02:03 PM
At first glace I would guess that it's down to a repeated image, but there's a lot to go over in your page - lots of code and dozens of scripts and other assets, which makes it rather offputting/daunting.

I would suggest breaking the page down until you're just left with the menu and it's dependant scripts. If you haven't located what's causing the extra dots/crosses while you're doing that, post a link to a more streamlined sample page and hopefully somebody will be able to take a look for you.

ajfmrf
03-22-2013, 06:12 PM
Well,I took the first menu and just got the following results

http://www.web-user.info/test/asset/index.html

No dots or bullets or what not at the end of this one.

I just took the css for the menu and the menu and stuck it on a page to see what it looked like.

When I come back I will make another page by adding the second menu.

Then a third page by adding the third and final menu to see what happens when each is added on.

Here it is with all three menus.No dots or bullets.

ajfmrf
03-22-2013, 08:43 PM
All of my testing leads to this as the problem:
http://www.seims-dlr.co.uk/index.php/2013-03-04-14-08-39/asset-hierarchy/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_801e9.css
It gives some correct css to the page and also causes the problem.

I have not had an opportunity to find the problem but here is what the file is:

opps-file is too large to post here

here is a copy of the file incase the above link does not work for some reason.

http://www.web-user.info/test/asset/problemcssfile.txt


This file has the questionable css file on it
http://www.web-user.info/test/asset/asset.html

this one does not.
http://www.web-user.info/test/asset/asset2.html

the second one does not have the extra dots and stuff but it also affects the other menu so something will have to be reworked

carolineleonard
03-26-2013, 04:22 PM
Hi Bud,

Thanks for looking into this. Unfortunately I am a novice coder so not sure how I will resolve the issue..:( A little outside my re-working capability)

The dots don't actually appear on the Ipad or Google Chrome - just Firefox and IE it seems..