PDA

View Full Version : Crawler image don't display



l_kcirtap
03-14-2013, 02:22 AM
1) Script Title: Text and Image Crawler v1.53

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex2/crawler/index.htm

3) Describe problem: The image don't display in the crawler box
It was working but I change the DOCTYPE for other reason and side effect
For unknown reason there was a <!-- before my old DOCTYPE for more unknown reason the crawler work good when it's there.
The old DOCTYPE was :
<!--
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
And I change it for :
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
the page is :
http://www.triathlonsherbrooke.com/index.php

Sory for the english, has you can see from the page I'm french

Thank you

jscheuer1
03-14-2013, 03:41 AM
That's a non-standard version of crawler used on that page. It goes up and down, not sideways. Pretty cute.

Anyways, by uncommenting the DOCTYPE you are invoking standards, which somehow robs the crawler of its height.

Looks like you can restore that by adding it to the init:


<script type="text/javascript">
marqueeInit({
uniqueid: 'mycrawler',
addDelay: 30,
style: {'height': '270px'},
inc: 3, //speed - pixel increment for each iteration of this marquee's movement
mouse: 'cursor driven', //mouseover behavior ('pause' 'cursor driven' or false)
direction: 'top',
random: true,
stopped: false,
moveatleast: 3,
neutral: 150,
savedirection: true
});
</script>

l_kcirtap
03-15-2013, 02:43 AM
Thanks
Works perfect now!