View Full Version : I.E. blocking DHTML content

11-15-2004, 04:54 PM
Hi all,

OK, so I worked out why Jim's DHTML menu was not working, but now I am really annoyed by my Internet Explorer. On my work computer, I have Win XP Pro, SP2, I.E. 6.0.2900 ... with the latest patches. When I view my site with Jim's Menu or other DHTML on a page,(I put Military clock on a page and it happens with that all by itself, so I know it is not just Jim's Menu) I.E. blips and the Information Bar comes up and says "To help protect your security, I.E. has restricted this file from showing active content that could access your computer. Click here for options...". I right click the menu and choose "Allow blocked content" and then a dialog box open saying "Allowing active content such as script and ActiveX controls can be useful, but active content might also harm your computer. Are you sure you want to let this file run active content?" I click yes and then the page comes up fine. Does anyone know what setting I have to change to stop this nonsense?

As an off shoot to this question, what is required to make the DHTML scripts work. I want to put a message under where the menus appear saying "If the menu does not appear here, you need to enable ?" I don't want to have duplicate pages to support ancient or disabled browsers. It is only a personal web site after all.

Thanks in advance,
John. :)

11-15-2004, 06:26 PM
Yep, known issue.

Upload the site and the information bar will go away.


11-16-2004, 02:05 AM
Thanks, I will give it a try tomorrow.


02-10-2005, 11:50 PM
This problem does not seem to be solved that simply. I am using this script and have reports from several users that they are experiencing this same problem. Any solutions?

02-11-2005, 09:17 AM
Tell them to reset their Internet Explorer security settings.
If they're on too high, the bar will appear.


08-14-2006, 07:57 PM
No fix for this, huh? Bummer, I really like this script and I can't have my IE fans have to click that bar every time they visit my site.

08-15-2006, 03:04 AM
This one just doesn't pass the logic test. Go to:


If that brings up the information bar, your security settings are too high. The menu will work live without the info bar in IE 6 with that browser's default settings.

Additionally, if you are surfing in IE with security settings so high for a reason (it is understandable) you really should consider getting a decent browser like FireFox or Opera.