View Full Version : Ultimate Fade in Slideshow works in development not in production

01-18-2013, 11:35 PM
1) Script Title: Ultimate Fade-in slideshow (v2.4)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

3) Describe problem: Script works fine in local development using MAMP on Mac with OSX Mountain Lion. However, when I upload to hosted server, I get nothing. I was doing my local previews with the same browser that is having the problem, FireFox 18.0. All files were uploaded.

url for problem: www.lillyconstructioninc.com/preview/index.php

Thanks for any help!


01-19-2013, 05:35 AM
Just for the sake of troubleshooting, try putting the contents of the gallery.js file back into the body of the web page and set all paths to images/js/CSS as absolute.

01-19-2013, 05:37 AM
That's sort of the right idea Beverleyh, but the wrong path, at least for the slideshow images.

There could also be other problems, but the images:

["../img/slides/aggregate.jpg", "", "", "", ""],
["../img/slides/welding.jpg", "", "", "",""],
["../img/slides/dozer.jpg", "", "", "", ""]

are all 404 Not Found. The correct paths are:

["img/slides/aggregate.jpg", "", "", "", ""],
["img/slides/welding.jpg", "", "", "",""],
["img/slides/dozer.jpg", "", "", "", ""]

It can be confusing. Using the relative path in an external script like that, the paths are relative to the page that the images are to appear on, not to the script. When in doubt, one may always use the absolute path:

["http://www.lillyconstructioninc.com/preview/img/slides/aggregate.jpg", "", "", "", ""],
["http://www.lillyconstructioninc.com/preview/img/slides/welding.jpg", "", "", "",""],
["http://www.lillyconstructioninc.com/preview/img/slides/dozer.jpg", "", "", "", ""]

01-21-2013, 07:36 PM
Thanks, John - the path was exactly what caused my problem. I do understand the issue of relative paths, but I never thought to look at that because it was working on my local development server. Any idea why it would have worked locally? Just pondering and aiming for deeper understanding. Meanwhile, problem fixed and I am moving on. Love the script, by the way!

01-21-2013, 08:39 PM
If it worked on the local server, the paths were correct on the local server. Either there were copies of the images in the mistaken path or the folder structure was simply correct on the local server. When things got transferred to the live server, either the folder structure changed or the copies of the images that were in the correct path weren't brought along.