PDA

View Full Version : Swiss Army slide show not showing in browsers



TequilaMB
01-15-2013, 03:21 AM
1) Script Title: Swiss Army Image Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/swissarmy/index.htm

3) Describe problem: Slide show is operating properly when previewed on Firefox with Dreamweaver, also when pointing the browser to the page where it is installed http://www.tmbstudios.com on my own computer. However, it's not showing in either IE or Chrome on my computer, and on other computers, not even showing in Firefox. Don't know what I've done wrong.

jscheuer1
01-15-2013, 06:01 AM
The arrays for slides, slides2, and slides3 are not defined. The slides2 and slides3 arrays are simply missing. You probably copied their initialization scripts even though you're not using them. If so, get rid of the red parts in the below:


. . . optional too. It is always last, either fourth after Width and Height or second after Slides_array_name.
//Usage: new inter_slide(Slides_array_name, Width, Height, Interval)
new inter_slide(slides, delay=4000)
</script>
</p>


<p>
<script type="text/javascript">
new inter_slide(slides2)
</script>
</p>


<p>
<div id="show3"><script type="text/javascript">
new inter_slide(slides3)
</script>
</div>
</p>

<h3>You may also want to visit our <a href="/webdesignservice.html">Website design</a>, <a href="/layout.html">Graphic Design &amp; Page Layout</a>, or <a href="/photoediting.html">Ph

The slides array is there but is followed by an HTML <strong></strong> tag within its script block so is throwing an error and not being used:


. . . slides[4] = ["slide5.jpg", "Nature's Window Outdoor sound monitors", "http://www.tmbstudios.com/products.asp?cat=Cameras+%26+Listening+devices&filter=nw3", "_new", "top=250, left=, width=700, height=500, location, resizable, scrollbars"];
slides[5] = ["slide6.jpg", "Nestbox Cams", "http://www.tmbstudios.com/products.asp?cat=Cameras+%26+Listening+devices&filter=bhsc", "_new", "top=250, left=300, width=700, height=500, location, resizable, scrollbars"];
slides[6] = ["slide7.jpg", "Nestboxes", "http://www.tmbstudios.com/products.asp?cat=Nestboxes+%26+Roosting+Boxes", "_new", "top=250, left=300, width=700, height=500, location, resizable, scrollbars"];
slides[7] = ["slide8.jpg", "Pet toys, beds &quot; dishes", "http://www.tmbstudios.com/categories.asp?cat=Pet+Supplies", "_new", "top=250, left=300, width=700, height=500, location, resizable, scrollbars"];
slides[8] = ["slide9.jpg", "Heated Birdbaths", "http://www.tmbstudios.com/products.asp?cat=Heated+birdbaths", "_new", "top=250, left=300, width=700, height=500, location, resizable, scrollbars"];
slides[9] = ["slide10.jpg", "Atlantic Liners books &quot; other items", "http://www.tmbstudios.com/categories.asp?cat=Atlantic+Liners+Products", "_new", "top=250, left=300, width=700, height=500, location, resizable, scrollbars"];



<strong></strong>
//above slide show uses only the defaults


</script>

<script src="swissarmy.js" type="text/javascript">

/***********************************************
* Swiss Army Image slide show script - John Davenpo . . .

Get rid of it (red in the above).

There could also be other problems, but that's probably it.

The browser cache may need to be cleared and/or the page refreshed to see changes.

TequilaMB
01-15-2013, 01:23 PM
That did it! Thanks!