PDA

View Full Version : Step Carousel Viewer v1.9 bug in jQ 1.8.x+



jscheuer1
11-23-2012, 05:12 PM
1) Script Title: Step Carousel Viewer v1.9

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/stepcarousel.htm

3) Describe problem: In jQuery 1.8.x+, this in stepcarousel.js is no longer a valid selector (around line #220):


createpaginate:function($, config){
if (config.$paginatediv.length==1){
var $templateimg=config.$paginatediv.find('img["data-over"]:eq(0)') //reference first matching image on page
var controlpoints=[], controlsrc=[], imgarray=[], moveby=$templateimg.attr("data-moveby") || 1
var asize=(mo . . ..

Nested quotes have never been required nor even suggested for attribute selectors, only for (if given) the attribute value in an attribute selector*. Now apparently they're not even allowed for the attribute. It can be fixed by dropping the nested quotes:


var $templateimg=config.$paginatediv.find('img[data-over]:eq(0)') //reference first matching image on page


*http://api.jquery.com/category/selectors/attribute-selectors/