PDA

View Full Version : Accordion script not opening in https: ?



MTuttle
11-16-2012, 04:53 PM
1) Script Title: Glossy Accordion Menu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/ddaccordionmenu-glossy.htm

3) Describe problem: I'm in the middle of a redesign here https://www.davidscottco.com/default.aspx?skinid=3 on an ASPstorefront site and am running into some issues with the accordion opening. In IE9 I get a "only showing secure items" message and the accordion menus won't open. In firefox the list items don't always load as well. In the "Categories" list, I'm also using a scrollbar script to define the height. Any ideas / help would be appreciated.

bernie1227
11-16-2012, 10:25 PM
I can't even get to your site, apparently there's something up with the security certificate:


The site's security certificate is not trusted!
You attempted to reach www.davidscottco.com, but the server presented a certificate issued by an entity that is not trusted by your computer's operating system. This may mean that the server has generated its own security credentials, which Google Chrome cannot rely on for identity information, or an attacker may be trying to intercept your communications.

MTuttle
11-19-2012, 07:17 PM
Hey Bernie,

That's weird, I can access it fine on FF, IE9, Chrome and Safari. Just the DD accordion script is giving me some trouble.

Matt

jscheuer1
11-19-2012, 10:12 PM
The page loads here. There could also be other problems but there are numerous references* to scripts and at least one stylesheet that begin with:

http:

These need to be changed to:

https:

Once you take care of all of those, the script should load up OK in IE 9. There may or may not be other problems with it and fixing this may or may not help Firefox. But it's a good start. Report back what happens.

The browser cache may need to be cleared and/or the page refreshed to see changes.



*I'm getting these errors (some may be duplicates) in IE 9's Developer Console (f12, Console tab, refresh the page):


SEC7111: HTTPS security is compromised by http://fonts.googleapis.com/css?family=Cardo:400italic
SEC7111: HTTPS security is compromised by http://fonts.googleapis.com/css?family=Cardo:400italic
SEC7111: HTTPS security is compromised by http://fonts.googleapis.com/css?family=Open+Sans:400,300,700,600,800
SEC7111: HTTPS security is compromised by http://fonts.googleapis.com/css?family=Open+Sans:400,300,700,600,800
SEC7111: HTTPS security is compromised by http://code.jquery.com/ui/1.9.1/themes/base/jquery-ui.css
SEC7111: HTTPS security is compromised by http://code.jquery.com/ui/1.9.1/themes/base/jquery-ui.css
SEC7111: HTTPS security is compromised by http://code.jquery.com/jquery-1.8.2.js
SEC7111: HTTPS security is compromised by http://code.jquery.com/ui/1.9.1/jquery-ui.js