PDA

View Full Version : Ultimate Fade-in slideshow (v2.4) image jumps in latest version of chrome



student101
10-23-2012, 09:41 AM
1) Script Title: Ultimate Fade-in slideshow (v2.4)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem:

Ultimate Fade-in slideshow random image locations in chrome 22.0.1229.94 m

I've searched these forums & chose to load a completely new page & yet the problem still exists.

Test link (http://olivegreencat.com/greg/fadein)

Works fine in these.
IE9 - Version 9.0.8112.16421
Firefox - Version 16.0.1

Windows 7 Ultimate

jscheuer1
10-23-2012, 11:03 AM
I can't see any difference that version of Chrome as opposed to That version of Firefox. Looks smooth, not jumpy and the same in both. What specifically should I be looking for?

I am using Win 7 Pro, not Ultimate, perhaps that's a difference, but I doubt it.

student101
10-23-2012, 02:22 PM
Perhaps my explanation was incorrect, my apologies.
Here are some screen shots

48134814

Based on that page, everything should work as expected but the images either go mostly top left or bottom right.

jscheuer1
10-23-2012, 07:50 PM
Nope. In my Chrome of that version it's respecting this style (from olivegreencat.com/greg/fadein/index.php line #28):


.wrapper #fadeshow1 {
width: 700px;
height: 600px;
margin: 0 auto 20px auto;
}

Which centers it horizontally. The script, unless you've edited it centers images that are smaller than the slideshow dimensions within the 700 x 600 box of the slideshow.

I'm thinking you might need to clear the cache in Chrome and reload the page. You might be seeing results in it from a previous version of the page. The fact that it does this in Safari too though, makes me uncertain. But that might also be the problem there. Both browsers are webkit, so their caches would work in a similar fashion.

It's weird though because in Chrome if I inspect the fadeshow1 element and see where it's getting its styles from, it says the above code, but if I look at the computed style or metrics, they're off with the right margin larger than the left, which would look like what you say (they should be equal). But the actual page in Chrome here appears with the slideshow and its images centered. I also tried various page sizes to see if that would throw it off, but it didn't.

student101
10-23-2012, 08:16 PM
Thanks for your response & time.
Best way forward would be to have images larger than 700px by 600px uploaded with the resize script to have it set size reatained.

I'll try play around with preloading images first.

jscheuer1
10-24-2012, 03:39 AM
I suppose. I mean that's a good idea. But none of the images I see are larger than that. The screen shots that you provided appear to involve images that are less than 700 x 600 as well. Are they?

student101
10-24-2012, 04:31 AM
Yes true, any image not 700px in width was part of the old attempts.