PDA

View Full Version : Resolved HTML is Broken



Kage Kazumi
10-16-2012, 03:08 AM
So well testing my page I noticed that some of the elements look like they are all in the same DIV. I went through it, but I'm pretty sure all my DIVs have the proper ending.

See the page here: http://zanime.net/test/

CSS: http://zanime.net/test/css/style.css

The page should look like the first 2 boxes.

EDIT

Well testing it locally I pinpointed the problem to this code:



<div class="tb-container"><!-- ENGINE001 start .TB-CONTAINER -->
<div class="tb-header">
<span>Engine001</span>
<span class="tb-header-os">Operating System:
<img class="windows" src="images/windows-logo-icon.png" alt="Windows">
</span>
</div><!-- end .tb-header -->

<img class="gd-image" src="images/gd-img/engine011.jpg" alt=""/>

<p class="tb-descripter">
The graphical scripter within 001 Game Creator is a simple, yet powerful method of creating events for your game without the difficulty of learning to write code. It uses the simplicity of pointing and clicking to allow the user to easily implement events in the form of a flowchart...(<a href="http://www.engine001.com/features.htm" target="_blank">Read More</a>)
</p>
<div class="tb-footer">
<span class="tb-footer-type"><span class="2d">2D</span></span>
<span class="tb-footer-price"><span class="free" class="commercial">Free/Commercial</span></span>
</div><!-- end .tbfooter -->
</div><!-- ENGINE001 end .TB-CONTAINER -->


If I add an extra DIV end tag it slightly fixes the issue, but then that entire DIV ends up slightly broken broken. See what I mean here: http://zanime.net/test/index2.html

The GAP at the top of Engine001 should not be there.
~Kage

jscheuer1
10-16-2012, 04:22 AM
First try validating the HTML code:

http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fzanime.net%2Ftest%2F

Kage Kazumi
10-16-2012, 04:30 AM
Thank you. Found the extra DIV and a few other errors. Bookmarked.