View Full Version : new script not loading on Apple

09-20-2012, 02:12 PM
I have just added this mouseover code "Image w/ description tooltip v2.0" and css to pages. I have been advised that the page does not load on Apple computers. I don't have Apple (pardon obvious) but they load and work on my Wxp,7 and IE8,9.


Any thoughts??

09-20-2012, 02:52 PM
This script is not loading:

<!doctype html>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script src="" language="javascript"></script>
<TITLE>the Victorian Cottage MORE INFO pages. . . . . . . . . . . ..</TITLE>
<STYLE type="text/css">
A.ssmItems:link {color:black;text-decoration:none;}
A.ssmItems:hover {color:black;text-decoration:none;}
A.ssmItems:active {color:black;text-decora . . .

That could just be a temporary network glitch. It does hold up the loading of the page. On certain Apple products it might prevent the page from loading.

What's that for? Do you need it?

09-20-2012, 03:28 PM
Thanks for your response, John.
Don't know what that line is. I checked old versions of pages and it does not appear on them. However, it is on current pages that work.

(working page is with uppercase "C" and new, not working page is lowercase "c" )

I don't know when or how it got added. Searching, that line seems to be discussed as an ISP added line to save bandwidth???

I'm guessing that it got added to my pages when I saved latest page to edit it and reupload. Not sure what I'm talking about ;o) but don't know if that has anything to do with original problem of not loading on Apple.

09-20-2012, 08:31 PM
just to clarify, this is all apple products? Or Mac laptops/desktops specifically?

09-20-2012, 10:54 PM
A lot more information will be necessary to figure out why it isn't working. Is this Mac computers or apple mobile devices? Is this with Safari? Firefox? Chrome? All browsers?

If what John pointed out fixed it, that's fine. But we can't debug it without knowing what's actually not working.

Secondly, if you're only using two computers to test it (one is yours, and one is this other mac you're referring to), then it could be the case that the script is cached on your system but not loading any more-- try clearing your cache and loading the page again. It might not work on any computer.

09-21-2012, 04:42 PM
Thanks for your replies. I'm contacting the person that first alerted me to a problem. Perhaps other followers of this forum could test the link -

I've had others test the page and most say it loads slowly. I spent 2 hours this morning checking each html file on my host and removing the inserted script While I was updating some of the pages, this bmi.js code was injected to my page while downloading to modify. Not seeing it, I saved the file and uploaded. That has now been cleaned up at the host: however, when visitors to the site load a page, it may be reinjected. I'm persuing that at another level (possible classaction).

As soon as I get info back from the original notifier, I will post.

Thank you, in advance, to anyone that is able to follow the above link and report results. FYI - 2 versions of the page are available 1) Cottage.html - old and working fine: 2)cottage.html - new and not loading fast/at all.


09-21-2012, 05:32 PM
That bogus script is not on the test page and it loads much faster. The tool tip is working.

09-21-2012, 07:38 PM
John -
When checking yesterday were you using a mobile broadband device? That stray script is injected to compress images. As I continue to dig, I'm learning more than I want to know :o(

Again, thank you.

09-22-2012, 01:38 AM
Nope, I don't have a mobile. I just meant that removing that script worked in speeding up page load and that the tip script was working. If that other script is added automatically when an Apple or other mobile is detected, then that's probably not such a hot idea. Images should be and often are already compressed anyway. And messing with images that are in other scripts might break those other scripts or mess up the page.