PDA

View Full Version : next and prev links not showing on Lightbox image viewer 2.03a



toolman
09-14-2012, 10:10 PM
1) Script Title: Lightbox image viewer 2.03a

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:

Hi,

I cannot get the next and previous buttons to show on my image.s I have given them a group in the rel tag, but it still doesn't work.

This is what I have:



<a href="images/image-1.jpg" rel="lightbox[test]"><img src="images/thumb-1.jpg" width="100" height="40" alt="" /></a>
<a href="images/image-1.jpg" rel="lightbox[test]"><img src="images/thumb-1.jpg" width="100" height="40" alt="" /></a>
<a href="images/image-1.jpg" rel="lightbox[test]"><img src="images/thumb-1.jpg" width="100" height="40" alt="" /></a>


Any ideas?

jscheuer1
09-15-2012, 02:18 AM
Unless you're using the linked caption feature, and even if you are, consider updating to a more recent version or changing to some other lightbox type script, as this version is quite outdated.

That said, the problem you're having is common in nearly all of the lightbox versions and nearly all of the lightbox type scripts. There can be other reasons, but usually it's because in the css file (lightbox.css for this script) the path to the next and previous images is incorrect. If you installed from the archive and kept everything in the same folders as in that archive, the paths were already correct. If you moved anything around, it's possible that the paths to those images are no longer correct in the css file. Paths in a css file are relative to the css file. If there is ever any doubt though, the absolute path to the images may be used.

If you want more help, please include a link to the page on your site that contains the problematic code so we can check it out.