PDA

View Full Version : link in slideshow doesn't work



myalo
09-06-2012, 06:53 PM
1) Script Title: Fade in Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem:
I added links to some of the images in the slideshow and it does not work.
I have different slideshow on our website and when adding links to them it works - we get the hand and it is clickable
On a certain one it used to work and now it doesn't
I looked carefully what has changed but cannot see the problem and need your help:
Link to the page http://wcce.ajula.edu/courselist.aspx
The js library iink Scripts/fadeslideshow.2-4.js
the script file that hold the creation of the slideshow http://wcce.ajula.edu/Scripts/InternalSlideshowWCCE.js
Here is its content:
// JavaScript Document


var mygallery=new fadeSlideShow({
wrapperid: "photoHeaderSlideshow", //ID of blank DIV on page to house Slideshow
dimensions: [953, 231], //width/height of gallery in pixels. Should reflect dimensions of largest image
imagearray: [
["../Images/wcceImages/internalSlidShow/40-Hours-to-Decide-231.jpg", "http://wcce.ajula.edu/forms/frwcce40.aspx", "", ""],
["../Images/wcceImages/internalSlidShow/real_housewives_bible.jpg", "http://www.ajula.edu/housewives", "", ""],
["../Images/wcceImages/internalSlidShow/Hanukkah-Family-FunDay.png", "", "", ""],
["../Images/wcceImages/internalSlidShow/ARCHAEOLOGY_2013.jpg", "", "", ""] //<--no trailing comma after very last image element!
],
displaymode: {type:'auto', pause:5000, cycles:0, wraparound:false},
persist: false, //remember last viewed slide and recall within same session?
fadeduration: 3000, //transition duration (milliseconds)
descreveal: "ondemand",
togglerid: ""
})

Please help
Thanks
myalo

jscheuer1
09-07-2012, 12:11 AM
The slideshow is covered by the messagesOnPicture div element. Set its display to none, and the links will work. This div is mentioned numerous times in the stylesheet. Here's one of the many places you could add that style - wcce.ajula.edu/Styles/custom_WCCE.css around line 74, addition highlighted:


.interior #messagesOnPicture { /* Used in this subsite to display the subsite logo over the slideshow. */
height: 231px;
display: none;
/* background-image: url(../images/wcceImages/subsiteLogo_interior.jpg); */

}

myalo
09-08-2012, 01:40 AM
The slideshow is covered by the messagesOnPicture div element. Set its display to none, and the links will work. This div is mentioned numerous times in the stylesheet. Here's one of the many places you could add that style - wcce.ajula.edu/Styles/custom_WCCE.css around line 74, addition highlighted:


.interior #messagesOnPicture { /* Used in this subsite to display the subsite logo over the slideshow. */
height: 231px;
display: none;
/* background-image: url(../images/wcceImages/subsiteLogo_interior.jpg); */

}

Thanks this was it.
The idea was to have the possible to lay on top of the picture / slideshow a message or logo. By mistake I made it as big as the slideshow. Now I specified much shorter height and the <a> works
Again thanks for helping me
myalo