PDA

View Full Version : Resolved Speech Bubbles not working with Explorer



wirefram
08-27-2012, 05:29 PM
script Speech Bubbles Tooltip
http://www.dynamicdrive.com/dynamicindex5/speechbubblestooltip.htm

I am pulling my hairs, the script works perfectly with Fireworks (my version is 14.0.1) and doesn't work at all with Explorer (my version 8.0.6).

I am using the script with an external file

you can see it on this page:

http://www.crystal-energy.com/pierres-et-mineraux-2213/aegirine-a-azurite-657/

When i check the samples of the script on dynamicdrive.com with the same Explorer everything works fine, so it must be something in my script configuration but i can't find what!


What can i do to make it work with Explorer too?

Thanks

L.

ddadmin
08-28-2012, 12:31 AM
Hmm at a glance everything looks correctly set up. To isolate the problem, try duplicating your page, then remove all the other scripts and CSS from that page to try to rule out one of them being the problem. If the issue persists, also start removing HTML content that isn't directly relevant to the bubble tooltip being shown.

The tooltip works in IE9 btw.

jscheuer1
08-28-2012, 03:43 AM
It's the:

http://www.crystal-energy.com/speechdata.txt

file. Around line 95 it has an extra </div> tag. I'm attaching a corrected version (right click and 'Save As'):

4704

Use it in place of your current one. Back up the current version first.

The browser cache must be cleared and the page refreshed in order for this change to take effect.

wirefram
08-28-2012, 12:00 PM
Wooooooo! That was THE problem, now it's working with IE 8!

I have spent hours trying just about everything, disabling other scripts, changing the CSS etc. and it was this </div> extra causing all troubles!

Many many thanks!

L.

wirefram
08-28-2012, 12:15 PM
Just trying to close the post as it has been resolved...

Thanks again

L.

jscheuer1
08-28-2012, 02:31 PM
OK, I'll close it then. You don't have that ability.

Glad it worked!