PDA

View Full Version : Trying to follow a script from this site.



theremotedr
07-31-2012, 06:01 PM
I have installed the scrip as per link below and works ok but need some advice.
When i place my mouse over the photo it shakes like it is supposed to but upon moving the mouse on & off the photo at different angles the shake is either ok or fast or very fast.
I am lost as to how to get it the same speed.

http://www.dynamicdrive.com/dynamicindex4/shake.htm

Thanks for any advice given.

jscheuer1
07-31-2012, 09:46 PM
Some might call that a feature.

For more consistent performance, use this slightly modified version:


<script type="text/javascript">

/*
Shake image script (onMouseover)-
Dynamic Drive (www.dynamicdrive.com)
For full source code, usage terms, and 100's more DHTML scripts, visit http://dynamicdrive.com
*/

//configure shake degree (where larger # equals greater shake)
var rector=3

///////DONE EDITTING///////////
var stopit=0
var a=1

function init(which){
stopit=0
shake=which
shake.style.left=0
shake.style.top=0
}

function rattleimage(){
clearTimeout(rattleimage.timer);
if ((!document.all&&!document.getElementById)||stopit==1)
return
if (a==1){
shake.style.top=parseInt(shake.style.top)+rector+"px"
}
else if (a==2){
shake.style.left=parseInt(shake.style.left)+rector+"px"
}
else if (a==3){
shake.style.top=parseInt(shake.style.top)-rector+"px"
}
else{
shake.style.left=parseInt(shake.style.left)-rector+"px"
}
if (a<4)
a++
else
a=1
rattleimage.timer = setTimeout("rattleimage()",50)
}

function stoprattle(which){
stopit=1
which.style.left=0
which.style.top=0
}

</script>

theremotedr
08-01-2012, 07:53 AM
Ok i will look thanks

theremotedr
08-01-2012, 08:47 AM
Thanks for the advice.
Somehow now i dont get any shake ?
What did i do wrong,could you look at the page in question and possibly advise.

http://www.ianparsons.info/zyx.htm

theremotedr
08-01-2012, 08:52 AM
HI
I have just put the original code in and it shakes.
I then removed the original & replaced it with the above then no shake ?

theremotedr
08-01-2012, 10:59 AM
I have now removed the script as i could not sort it out so having to think of another script to use,thanks

jscheuer1
08-01-2012, 03:23 PM
That seems perhaps a bit impatient. Perhaps one of us made a typo. I tested it and it works:

http://home.comcast.net/~jscheuer1/side/shake/shake.htm

You can use your browser's "View Source" to get the working code. Or if there is a problem with the above demo, perhaps it's browser specific. In that case which browser are you using?

If you want me to fix your implementation, please include a link to the page on your site that contains the problematic code so we can check it out.

theremotedr
08-01-2012, 03:57 PM
Sorry about that,didnt mean to upset anyone.
I have come away from that idea now and just using the photos.

Thanks for the reply anyhow.

theremotedr
08-03-2012, 07:37 AM
In my inbox today was an email to say that there was a reply to this thread by "username" but when i look i see no reply from that person ?

Any advice.

djr33
08-03-2012, 07:44 AM
It was a spam message, unrelated to your topic. (It has now been deleted.)

theremotedr
08-03-2012, 07:46 AM
Ok
But i clicked on the link to come to this page but then i did not see the reply.

By me clicking the link to come here has anyone got any info from me ?

bernie1227
08-03-2012, 07:51 AM
What do you mean by "got info from you by clicking the link"? It was simply spam post that has been deleted.

theremotedr
08-03-2012, 08:10 AM
What i mean was,i received the email of which i clicked the link to come to this page only to find out that there is no reply.
Since been told it was a spam email.

My question is,by clicking on the link has any info about me etc been sent to the person who sent it to me or is it harmless and just delete it ?
There is no fault with this site,i possibly did not explain correctly.

bernie1227
08-03-2012, 08:25 AM
Well the real question is, who sent it? Are you getting automatically emailed every time one of your threads is updated? Because if that is the case, then theres not actually any problem, as all that happened was an automated email in which by the time you clicked the link, the post had been deleted.

If someone did manually send you an email saying that they had posted on your thread (which seems quite unlikely), there isn't really much personal information they could glean from that, and since the link is going to dynamic drive, the only kind of information they would have would be your email address.

My guess is that the former happened.

theremotedr
08-03-2012, 08:28 AM
Hi,
Yes i receive an email from this site when there is an update.

Thanks for the advice.

bernie1227
08-03-2012, 08:31 AM
Like I said before, it was an automated email, and Daniel had obviously deleted the post before you clicked on the link.

djr33
08-03-2012, 08:44 AM
The post on the forums was spam, but the email was sent automatically by the board before the post was deleted. You didn't click a spam link. I understand your confusion, but there is nothing to worry about.

Note: you can manage your personal notification settings. If you want to be notified of new posts, that will happen automatically when there is a reply. If a moderator deletes the post, the email will have already been sent, so it will not be possible to "unsend" the email. In that case, there will be no reply. That's slightly inconvenient, but there's nothing we can do about that. I hope that makes sense.

(Also, the post didn't have anything to do with your topic at all, nothing personal, just a generic ad.)

theremotedr
08-03-2012, 08:45 AM
Thats the reply i needed,thanks very much.

jscheuer1
08-03-2012, 11:20 AM
By clicking the link you've condemned yourself, your children and your children's children to a life of servitude in the Asian spam factories.

We're very sorry, but there's nothing we can do about it. :)