PDA

View Full Version : Script compatibility with Mozilla Firefox 1.0



pldobs
11-12-2004, 03:08 PM
With the production release of Firefox and it's increasing popularity. . . Maybe it would be a good idea to add information to the site indicating which scripts are and are not compatible with Mozilla Firefox. By the way, if you haven't tried Firefox 1.0, I highly recommend it.

cr3ative
11-12-2004, 03:12 PM
Ah, this would be a meritable addition, however I should expect it would take an age to test throughly all the scripts for compatibility. I'm sure it'll be done in the future.

cr3ative

Bintaur1
11-18-2004, 04:44 PM
Have been trying for the last week to get two of my scripts to work with Firefox 1.0. Work fine in IE but then we all know IE doesn't follow strict //W3c// Doctype HTML rules whereas Firefox 1.0 does. Here are the two scripts that will not work in Firefox:

1) Conveyor belt slideshow script: http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm

To be Noted: I am using the older version of Conveyor Belt as I have not been able to get the newer version shown at the above link to function properly even in IE especially given that I do not want to use a slidebgcolor with it. The page using the conveyor belt script is here: Tylers Xmas Page (http://www.tylersgliderplace.homestead.com/Xmas2.html)

2) 3D Starfield: http://www.dynamicdrive.com/dynamicindex3/starfield.htm

The page using the 3D Starfield is here: Halloween Time (http://www.tylersgliderplace.homestead.com/Halloween.html)

Me thinks that a lot of javascripts are MS proprietary-based for IE & thus will not work in Firefox 1.0 which is a real shame as I generally like Firefox 1.0..

ddadmin
11-18-2004, 08:36 PM
We plan on updating the compatibility index to match the current times. This means most likely Firefox will be included, and NS6 taken out. It's still in the works, but rest assured we're aware that the compatiblity index is way outdated. :)

Regarding DD scripts actually working in Firefox, I think you'll find the majority do, at least scripts added in the last couple of years. We always test newly added scripts in both IE6, Firefox, and Opera 7. The current version of the Conveyor Belt script should work in Firefox without problems.

Bintaur1
11-18-2004, 11:23 PM
Thanks for the reply, DDADMIN! Nice to know that things will get updated in the near future. As for the current version working in Firefox 1.0, you're probably right but for the moment I'm having problems getting it to even work in IE but I'll keep trying. :o