PDA

View Full Version : More than one image crawler in same page does not work fine.



sofiag
06-13-2012, 10:08 PM
1) Script Title: Text and Image Crawler v1.5

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex2/crawler/index.htm

3) Describe problem: When trying to put two image crawlers in the same page, the second creates a big space around.
I mean, I put one and all is ok. I add another one and the second presents that problem. But, if I delete the first, the second works fine.

Also I tried to put three. The first and the second work fine, but not the third. It seems that it is always the last that presents the problem.

I read that "OO code allows as many marquees on the page as one wants". Perhaps there is the problem, but I do not know what is "OO code".

Any help would be appreciated!
Sofía

jscheuer1
06-14-2012, 02:15 AM
Look at:

http://home.comcast.net/~jscheuer1/side/thecrawl/

As you probably can see there's no problem like what you're describing. There are 4 crawlers.

If there's a problem on that page, it might be your browser. If so, what browser are you using?

If it works OK, you may have discovered a bug. More likely it's something in your implementation.

Either way, we can't help you without seeing your page:

If you want more help, please include a link to the page on your site that contains the problematic code so we can check it out.


BTW - OO code is Object Oriented. It means that the crawler is an object that can be reused, as opposed to some scripts that can only be used once on a page.

sofiag
06-14-2012, 01:57 PM
Thank you very much, John!!!

The problem is solved (it was not the script, it was me!). The url you sent helped me to find that I had left a piece of useless script in the middle of both scrollers. Now, all is ok.

Thanks, thanks, thanks :)

Sofía