PDA

View Full Version : Resolved Continuous Reel Slideshow and Ajax Livesearch



packetloss
05-15-2012, 10:31 PM
1) Script Title: Continuous Reel Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/reelslideshow.htm

3) Describe problem: When I add the slideshow to a page that has an Ajax livesearch - that functionality stops when reelslideshow.js is included. I cannot determine why this is happening.

The javascript for the livesearch is sourced in the last line before </body>




function findValue(li) {

if( li == null ) return alert("No match!");

// if coming from an AJAX call, let's use the CityId as the value

if( !!li.extra ) var sValue = li.extra[0];

// otherwise, let's just display the value in the text box

else var sValue = li.selectValue;

//alert("The value you selected was: " + sValue);

}



function selectItem(li) {

findValue(li);

}



function formatItem(row) {

return row[0];

}



function getBusinessId() {

return 'top-business';

}



$("#zip").autocomplete("page2.php", {

delay:5,

minChars:1,

matchSubset:1,

matchContains:1,

cacheLength:10,

onItemSelect:selectItem,

onFindValue:findValue,

formatItem:formatItem,

extraParams:{b:getBusinessId()},

maxItemsToShow: 12,

//autoFill:true

}

);





$("#business").autocomplete("page1.php", {

delay:5,

minChars:1,

matchSubset:1,

matchContains:1,

cacheLength:10,

onItemSelect:selectItem,

onFindValue:findValue,

formatItem:formatItem,

maxItemsToShow: 12,

//autoFill:true

}

);

ddadmin
05-15-2012, 11:01 PM
Inside reelslideshow.js, try commenting out the line below (addition in red):


//jQuery.noConflict()

If that doesn't help Pplease post a link to the page on your site that contains the problematic script so we can check it out.

packetloss
05-15-2012, 11:09 PM
I tried that earlier after some research about noConflict(). I guess I kept reloading the page too fast after doing comment-save-test-uncomment-save-test because now it works...

Before posting I even did ctrl+F5 a few times after commenting-saving.

Thanks ddadmin : )

packetloss
05-15-2012, 11:10 PM
Btw there is a problem trying to "Thank" you ddadmin:

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 55

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 107

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 111

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 119

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 130

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 134

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 142

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 211

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/init.php on line 389

Deprecated: Assigning the return value of new by reference is deprecated in /home/gchiang/public_html/forums/includes/class_core.php on line 2552

djr33
05-16-2012, 06:17 AM
That's a known issue that will be fixed. It started happening after a new update was applied.