View Full Version : ddlevelsmenu - mobile browser issue

03-26-2012, 10:07 PM
1) Script Title:

2) Script URL (on DD):

3) Describe problem:
I thought I'd check in again with this issue.
I just looked at the newest version of the script, and on my Android phone I'm still having the same issue (default Android browser):
I'm on your main site using the link above. On a small screen, I have to zoom in to read the page properly, so I'm zoomed in.
I can click the "DHTML" menu, and the sub menu opens. Then I click "Item Folder 3a" sub menu, and the sub menu opens.
So far so good.
But then I cannot click on any of the "Sub Item" entries. If I click on one, the visible part of my screen moves sideways by a bit, but I can't click on the menu entries. Nothing happens except the screen moving sideways.

The same happens with the main "Item" entries between the folders, i.e. "Item 1a" etc. cannot be clicked, either - only the "Item Folder" entries work on my phone.

I was wondering if you had any idea on how this could possibly be fixed.

I have an Android phone and a tab and am definitely willing to help testing. I know JS well enough for what I usually need, but most of your code is a little beyond me. Feel free to contact me directly if you prefer.

Also, please let me know if you need more information.


03-30-2012, 09:58 PM
Sorry for the delay in response. You say:

But then I cannot click on any of the "Sub Item" entries. If I click on one, the visible part of my screen moves sideways by a bit, but I can't click on the menu entries. Nothing happens except the screen moving sideways.

Have you tried hyperlinking one of the sub item entries then clicking it again? I have an Android tablet, and clicking on one of these entries takes me to the destination URL as expected.

03-30-2012, 10:03 PM

No worries about the delay - I bet you're constantly busy!

I'm not sure what you mean with "hyperlinking" in this case.
Can you elaborate a little?
(I know a good bit about programming, but I may not know all the correct terms since I'm mostly self-taught...)

I tried your demo right on the ddlevelsmenu page on my Android phone - do the menu items there have hyperlinking?


03-31-2012, 08:39 PM
I simply mean that if you click on any of the end sub menu items in the DD demo right now, it doesn't go anywhere, since each item's href attribute is set to "#". Try changing one of them to an actual URL, then click it again to see if it works.

04-02-2012, 02:09 PM
Oh, I'm so sorry I didn't catch that right away... :-)

I'll try it out and will let you know.

Thanks so much!

04-02-2012, 03:09 PM
OK, tried it - I copied your current ddlevelsmenu.zip file to a server and edited demo.htm to have a few marked links point to existing pages.
I still am not able to click sub folder links reliably.

In my example, I took the "DHTML" menu (ddsubmenu1), and under ITEM FOLDER 5a I replaced "Item Folder 5.1a" with the title ONE and a real like to file "01.htm".
In the sub menu "Item Folder 5.2a", I replaced the first two links.

Clicking on "DHTML" always opens the next level.
Clicking "Item Folder 5a" also nearly always opens the next level.
But starting from here, I get very erratic behavior.
Sometimes nothing happens at all if I click on my link "ONE" or on "Item Folder 5.2a", sometimes the entire menu simply goes away, and may 5% of the time the link works.
I tried zooming in and out, and sometimes that makes a difference and sometimes it doesn't.

I am using an Android phone, so the screen is considerably smaller than your tab, so some zooming is usually necessary to see everything, and sometimes you have to move the screen around to see the newly opened sub menu. So I'm wondering if that might have anything to do with it.
... nope, I just reloaded the page at original zoom level. Once I go past the first opening menu, things get inconsistent for some strange reason.

Interesting is that Android Firefox works flawlessly, just the built-in browser doesn't work.

The weird thing is the inconsistency of the Android browser in this - every once in a while a click will work, most of the time it won't...

Is it working consistently on your Android Tab? What OS version do you have on it? (I'm on Ginger Bread).

I'll have to bring my Tab back into the office to test and see if it's just the phone version of the browser.

I really wish there was a developer console for the Android browser :-)