PDA

View Full Version : Expandable Sticky bar conflicting with fancybox java



druggedoncolor
03-13-2012, 04:58 AM
1) Script Title: Expandable Sticky Bar

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/stickybar.htm

3) Describe problem: I am trying to add a footer using the expandable sticky bar script as solution for my one page... I am having issues with it conflicting with the fancybox java. Any help would be great!http://kglyphics.com

jscheuer1
03-13-2012, 03:39 PM
There could also be other problems but, this:


<!-- Add jQuery library --><script src="/js/expstickybar.js"></script>
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.7/jquery.min.js"></script>

Should be:


<!-- Add jQuery library -->
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.7/jquery.min.js"></script>
<script src="/js/expstickybar.js"></script>

But now fancybox doesn't work. To fix that:

Using a text only editor like NotePad, open up the expstickybar.js file and comment out the jQuery.noConflict() statement as shown:


/*Expandable Sticky Bar (Initial: Nov 1st, 2010)
* This notice must stay intact for usage
* Author: Dynamic Drive at http://www.dynamicdrive.com/
* Visit http://www.dynamicdrive.com/ for full source code
*/

//jQuery.noConflict()

function expstickybar(usersetting){
var setting=jQuery.extend({positi . . .

Save and use that version.

The browser cache may need to be cleared and/or the page refreshed to see changes.

druggedoncolor
03-13-2012, 03:47 PM
Thanks John! When I get the chance I'll try it.