PDA

View Full Version : ddimgtooltip problem



randallmedia
02-22-2012, 05:51 PM
1) Script Title: ddimgtooltip

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/imagetooltip.htm

3) Describe problem:
I have 90+ different areas that need to have the ddimgtooltip working (http://randallmedia.com/fairway/homes.php) but for some reason I can only get the first 14 to work. Is there a limit to how many you can do on one page?

ddadmin
02-22-2012, 08:43 PM
Hmm it shouldn't matter how many tooltips you have defined. Looking at your .js file, the only issue I can see at a glance is the trailing comma you have at the end of each of the lines below, which may fumble IE browsers:


tooltips[0]=["images/sold.jpg", "<h2>Property Sold</h2>", {background:"#E6E8FA", color:"black", border:"1px solid #d3d3d3",}]

You might try doing a search and replace to quickly remove them all, such as replacing all instances of ",}] with }]. Other than that issue, I don't see anything else (not to say there necessarily isn't any).

traceyr
04-03-2012, 04:37 PM
Hi, the good news I can give is that I have 70 image pop-ups which work fine on one page; the not-so-good news is that the remaining tips don't (yet) appear; I need eventually over 200! The script seems to be comfortable with gaps in the tip number sequence (mine are sequential from zero to 66, then 72,84,96,97,106, ... etc.).
The tips up to and including 96 in the sample below do pop up, 97 ff. don't, not even the empty window with caption being displayed.
The (Netobjects Fusion) hotspots are there (causing the pointer arrow to show as a hand in IE9) and the alt-text doesn't show on every hotspot, but that's nothing to do with ddimgtooltip.

tooltips[66]=["../assets/images/N-66.JPG","Nr. 66<br /> No. N-LXVI"]
tooltips[72]=["../assets/images/SW-06.JPG"," Nr. SW-06"]
tooltips[84]=["../assets/images/SW-18.JPG","Nr. SW-18"]
tooltips[96]=["../assets/images/SW-30.JPG","Nr. SW-30"]
tooltips[97]=["../assets/images/W-01.JPG","Nr. W-01"]
tooltips[106]=["../assets/images/W-10.JPG","Nr. W-10"]

Puzzling :confused:

traceyr
04-03-2012, 10:44 PM
Puzzle partially solved: I had not "escaped" special characters such as semi-colon and colon in some desc parameters. This seems to have led to the unpredictable behaviour of the script, although I can't be certain of this. At least my last tooltip (no. 204, the 80th) is now showing.:)