View Full Version : Using https with ddsmoothmenu down and right arrows

02-11-2012, 03:47 AM
1) Script Title: ddsmoothmenu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm

This is the line of code that is actually a problem

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>


3) Describe problem: I am attempting to utilize ddsmoothmenu on a certified ssl https site. It would appear that when I run the site I get a certification failure.

I suspect the culprit is the down and right arrowclass segment of the js code but have tried to add my URL https://www.changenyou.ca/images/down.gif to the class for down and right however am still getting errors on certification. Are there other code segments I will need to change to be able to run this on ssl certified site?

The file works perfect as http.

Any help greatly appreciated as I am an amateur programming a services site for a friend and would love to have it totaly operational ASAP.

By the way ddsmooth has been an amazing asset and except for this one glitch I have had very few problems customizing to my own requirements. Excellent piece of code.


02-11-2012, 04:17 AM
As long as the images are on the same ssl as the page, they cannot be the problem. However, this (from Step 1 on the demo page):

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>

Will be a problem. And of course, without the script, the images will not be displayed.

Google hosts its ajax lib scripts on a ssl as well as regular http, so you can try:

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>

If that doesn't solve the problem you can download a copy of jQuery and host it yourself from your ssl.

As a side note though, jQuery 1.3.2 is way outdated, so along with changing to https, I would suggest changing the number to 1.6.4, so you would have:

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js"></script>

And, again as I say, if you're still getting a security warning, download the file and host it yourself on your ssl.

The browser cache may need to be cleared and/or the page refreshed to see changes.

If you want more help, please post a link to the page on your site that contains the problematic code so we can check it out.

02-11-2012, 04:33 AM
I actually eliminated code till i found this one segment thanks you. I did not realize it was https hosted.

The resources and support here are fantastic again thanks.


02-11-2012, 05:03 AM
Since this is already solved, I'll interrupt with a question: John, is there any reason that updating the version of jQuery would be a bad idea? I mean, could that potentially create compatibility conflicts? I really don't know, so I'm just wondering. Or do you just know this script well and know that there won't be problems, but there might be for other scripts?

Doug, if you end up with more questions about this, feel free to turn the question back toward that! Also, just wondering, did you fix it by using Google's https server, or your own?

02-11-2012, 05:30 AM
Updating can be bad in some cases. I just checked, jQuery (on the Google ajax libs site) is still only up to 1.7.1. But I've seen some problems with it. Version 1.3.2 has some issues (Like with IE 9 and perhaps Firefox 10) because it's old and predates them. 1.7.1 is shaky because it's new and probably not the last in the 1.7 series. 1.6.4 is the last in the 1.6 series so is very stable and still very current. This has also been borne out in my experience - I work with the various version visa vis Dynamic Drive and other scripts a lot.

But this is all more or less just rule of thumb. I tell people what is most likely the best course of action based upon experience. If there's a problem we can always downgrade. There are a few other choices (1.5.2 and 1.4.4) both better than 1.3.2 in most cases.

More often than not though updating to the most recent stable version fixes rather than causes issues. After all, that's one of the main reasons for new versions. And jQuery syntax hasn't changed in any major script breaking way since the transition from 1.2 series to 1.3 series and even that only affects certain usages.

By the way, I also just checked the OP's page, they fixed the issue by using the Google ssl version.

02-11-2012, 05:39 AM
Good to know, thanks!