View Full Version : Advanced RSS ticker (Ajax) - initializing script...

01-25-2012, 01:56 PM
1) Script Title: Advanced RSS ticker (Ajax invocation)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/rsstickerajax/index.htm

3) Describe problem: I'm having the same problem as is seems multiple other users have reported without any resolution. (Environment - Hostgator cPanel shared hosting). I have downloaded the demo files and uploaded to a sub-directory /rss on the server. Double and triple checked that the paths and necessary values match as needed for my install location. The script is not executing to display the RSS feeds, and gets stuck at the point where a message reads in the RSS feed area "initializing script...". I have tried enabling & disabling cache value, made sure the cache directory has correct read/write permissions, checked PHP info, verified that server is capable of importing RSS via a small PHP file, and I'm flat out of ideas. It seems the solution is a simple one, but it eludes me. This is a very nice looking & handy script...would be great if someone out there has an idea what's causing this "initializing script..." issue. Can't figure out why it would work just fine on the demo link at DD and yet the downloadable demo files seem to be broken. Thanks for any help you guys have to offer on this.

Just noticed, in the rssticker.js file on line 6, I can change the lastrssbridgeurl="lastrss/bridge.php" to lastrssbridgeurl="foobar.php", and it doesn't make any difference...the output on demo.htm still shows "initializing script..." where the RSS feeds are supposed to appear. If I change it to lastrssbridgeurl="" then it does generate an error message saying "Error fetching remote RSS feed!". So it would appear that there is an issue with the script not communicating with the bridge.php file correctly.

//Relative URL syntax:
var lastrssbridgeurl="lastrss/bridge.php"

//Absolute URL syntax. Uncomment below line if you wish to use an absolute reference:
//var lastrssbridgeurl="http://"+window.location.hostname+"/lastrss/bridge.php"

01-25-2012, 06:58 PM
Please post a link to the page on your site that contains the problematic script so we can check it out.

01-26-2012, 04:29 AM
Thanks. Sure thing, here's the url - maxonit.com/random/rss/demo.htm

01-27-2012, 03:35 AM
Hmm are you sure your server is set up properly to run PHP files? Right now if I call bridge.php directly: http://maxonit.com/random/rss/lastrss/bridge.php it returns a "500 Internal Server Error". It's not exactly the most informative message and could mean a whole range of possible issues, but the bottom line is the server cannot successfully run the script.

Try tweaking your server settings and after each change, run http://maxonit.com/random/rss/lastrss/bridge.php again to see if the error disappears.

01-27-2012, 08:43 AM
I'm using Hostgator. Never really had issues with 99% of the many scripts I've tried. They do a pretty good job of keeping PHP, mySQL, etc up to date and I've found over time the server fulfills the requirements of most scripts. What are the server settings I should be looking to check? I can run a php info and check if you let me know. There are a number of forum entries regarding the initializing script issue...I can't find a resolved thread.

01-27-2012, 09:11 AM
Weird thing. I found the script demo on this site http://www.ajaxdaddy.com/ajax-rssticker.html and it was stuck on "initializing script..." as well. I went and changed the editable java page below, changing the domain path to a bad value, and it broke it of course. But when I went and changed the domain path back to the correct/original value (the domain name of the demo), the script began to work. Strange?!

01-27-2012, 04:16 PM
Your server might have raised security settings that prevent PHP from writing to a directory, among other things. It's very hard to speculate, as "500 Internal Server Error" covers a whole laundry full of things.

At the end of the day if nothing works, you might try gAjax RSS Ticker (http://www.dynamicdrive.com/dynamicindex18/gajaxrssticker.htm), which doesn't require any server side installation to work.

01-29-2012, 07:40 AM
Aha. The bridge.php file was 755, I changed to 644. The script still does not work, stuck on initializing script..., but at least the bridge.php error can be viewed in the browser. maxonit.com/random/rss/lastrss/bridge.php . Are there any other permissions for files folders that I should double check besides cache 777. Thanks for your assistance on this.